Libsndfile and PostgreSQL Updates for Gentoo Linux
Posted on: 11/30/2018 10:56 AM

The following updates has been released for Gentoo Linux:

GLSA 201811-23 : libsndfile: Multiple vulnerabilities
GLSA 201811-24 : PostgreSQL: SQL injection

GLSA 201811-23 : libsndfile: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201811-23
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: libsndfile: Multiple vulnerabilities
Date: November 30, 2018
Bugs: #618016, #624814, #627152, #631634, #660452
ID: 201811-23

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in libsndfile, the worst of
which might allow remote attackers to cause a Denial of Service
condition.

Background
==========

libsndfile is a C library for reading and writing files containing
sampled sound.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-libs/libsndfile < 1.0.28-r4 >= 1.0.28-r4

Description
===========

Multiple vulnerabilities have been discovered in libsndfile. Please
review the CVE identifiers referenced below for details.

Impact
======

A remote attacker, by enticing a user to open a specially crafted file,
could cause a Denial of Service condition or have other unspecified
impacts.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All libsndfile users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot -v ">=media-libs/libsndfile-1.0.28-r4"

References
==========

[ 1 ] CVE-2017-12562
https://nvd.nist.gov/vuln/detail/CVE-2017-12562
[ 2 ] CVE-2017-14634
https://nvd.nist.gov/vuln/detail/CVE-2017-14634
[ 3 ] CVE-2017-6892
https://nvd.nist.gov/vuln/detail/CVE-2017-6892
[ 4 ] CVE-2017-8361
https://nvd.nist.gov/vuln/detail/CVE-2017-8361
[ 5 ] CVE-2017-8362
https://nvd.nist.gov/vuln/detail/CVE-2017-8362
[ 6 ] CVE-2017-8363
https://nvd.nist.gov/vuln/detail/CVE-2017-8363
[ 7 ] CVE-2017-8365
https://nvd.nist.gov/vuln/detail/CVE-2017-8365
[ 8 ] CVE-2018-13139
https://nvd.nist.gov/vuln/detail/CVE-2018-13139

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201811-23

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5




GLSA 201811-24 : PostgreSQL: SQL injection
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201811-24
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: PostgreSQL: SQL injection
Date: November 30, 2018
Bugs: #670724
ID: 201811-24

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A SQL injection in PostgreSQL may allow attackers to execute arbitrary
SQL statements.

Background
==========

PostgreSQL is an open source object-relational database management
system.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-db/postgresql *< 9.3.25 *>= 9.3.25
*< 9.4.20 *>= 9.4.20
*< 9.5.15 *>= 9.5.15
*< 9.6.11 *>= 9.6.11
*< 10.6 *>= 10.6
< 11.1 >= 11.1

Description
===========

A vulnerability was discovered in PostgreSQL's pg_upgrade and pg_dump.

Impact
======

An attacker, by enticing a user to process a specially crafted trigger
definition, can execute arbitrary SQL statements with superuser
privileges.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PostgreSQL 9.3.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.3.25"

All PostgreSQL 9.4.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.4.20"

All PostgreSQL 9.5.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.5.15"

All PostgreSQL 9.6.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.6.11"

All PostgreSQL 10.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/postgresql-10.6"

All PostgreSQL 11.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/postgresql-11.1"

References
==========

[ 1 ] CVE-2018-16850
https://nvd.nist.gov/vuln/detail/CVE-2018-16850

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201811-24

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5







Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/libsndfile_and_postgresql_updates_for_gentoo_linux.html)