Libraw, Singularity, Polkit Updates for openSUSE
Posted on: 01/11/2019 06:43 AM

The following updates has been released for openSUSE:

openSUSE-SU-2019:0008-1: moderate: Security update for libraw
openSUSE-SU-2019:0009-1: important: Security update for singularity
openSUSE-SU-2019:0010-1: moderate: Security update for polkit

openSUSE-SU-2019:0008-1: moderate: Security update for libraw
openSUSE Security Update: Security update for libraw
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0008-1
Rating: moderate
References: #1097975 #1103200 #1103206
Cross-References: CVE-2018-5804 CVE-2018-5813 CVE-2018-5815
CVE-2018-5816
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

This update for libraw fixes the following issues:

The following security vulnerabilities were addressed:

- CVE-2018-5813: Fixed an error within the "parse_minolta()" function
(dcraw/dcraw.c) that could be exploited to trigger an infinite loop via
a specially crafted file. This could be exploited to cause a
DoS.(boo#1103200).
- CVE-2018-5815: Fixed an integer overflow in the
internal/dcraw_common.cpp:parse_qt() function, that could be exploited
to cause an infinite loop via a specially crafted Apple QuickTime file.
(boo#1103206)
- CVE-2018-5804,CVE-2018-5816: Fixed a type confusion error in the
identify function (bsc#1097975)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-8=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

libraw-debuginfo-0.18.9-lp150.2.3.1
libraw-debugsource-0.18.9-lp150.2.3.1
libraw-devel-0.18.9-lp150.2.3.1
libraw-devel-static-0.18.9-lp150.2.3.1
libraw-tools-0.18.9-lp150.2.3.1
libraw-tools-debuginfo-0.18.9-lp150.2.3.1
libraw16-0.18.9-lp150.2.3.1
libraw16-debuginfo-0.18.9-lp150.2.3.1


References:

https://www.suse.com/security/cve/CVE-2018-5804.html
https://www.suse.com/security/cve/CVE-2018-5813.html
https://www.suse.com/security/cve/CVE-2018-5815.html
https://www.suse.com/security/cve/CVE-2018-5816.html
https://bugzilla.suse.com/1097975
https://bugzilla.suse.com/1103200
https://bugzilla.suse.com/1103206

--



openSUSE-SU-2019:0009-1: important: Security update for singularity
openSUSE Security Update: Security update for singularity
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0009-1
Rating: important
References: #1111411
Cross-References: CVE-2018-19295
Affected Products:
openSUSE Leap 15.0
openSUSE Backports SLE-15
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for singularity to version 2.6.1 fixes the following issues:

Security issues fixed:

- CVE-2018-19295: Fixed a local root exploit, related to joining arbitrary
mount namespaces (boo#1111411).


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-9=1

- openSUSE Backports SLE-15:

zypper in -t patch openSUSE-2019-9=1



Package List:

- openSUSE Leap 15.0 (x86_64):

libsingularity1-2.6.1-lp150.2.6.1
libsingularity1-debuginfo-2.6.1-lp150.2.6.1
singularity-2.6.1-lp150.2.6.1
singularity-debuginfo-2.6.1-lp150.2.6.1
singularity-debugsource-2.6.1-lp150.2.6.1
singularity-devel-2.6.1-lp150.2.6.1

- openSUSE Backports SLE-15 (aarch64 ppc64le s390x x86_64):

libsingularity1-2.6.1-bp150.3.6.1
singularity-2.6.1-bp150.3.6.1
singularity-devel-2.6.1-bp150.3.6.1


References:

https://www.suse.com/security/cve/CVE-2018-19295.html
https://bugzilla.suse.com/1111411

--



openSUSE-SU-2019:0010-1: moderate: Security update for polkit
openSUSE Security Update: Security update for polkit
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0010-1
Rating: moderate
References: #1118277
Cross-References: CVE-2018-19788
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for polkit fixes the following issues:

Security issue fixed:

- CVE-2018-19788: Fixed handling of UIDs over MAX_UINT (bsc#1118277)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-10=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

libpolkit0-0.114-lp150.2.6.1
libpolkit0-debuginfo-0.114-lp150.2.6.1
polkit-0.114-lp150.2.6.1
polkit-debuginfo-0.114-lp150.2.6.1
polkit-debugsource-0.114-lp150.2.6.1
polkit-devel-0.114-lp150.2.6.1
polkit-devel-debuginfo-0.114-lp150.2.6.1
typelib-1_0-Polkit-1_0-0.114-lp150.2.6.1

- openSUSE Leap 15.0 (x86_64):

libpolkit0-32bit-0.114-lp150.2.6.1
libpolkit0-32bit-debuginfo-0.114-lp150.2.6.1

- openSUSE Leap 15.0 (noarch):

polkit-doc-0.114-lp150.2.6.1


References:

https://www.suse.com/security/cve/CVE-2018-19788.html
https://bugzilla.suse.com/1118277

--






Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/librawsingularitypolkit_updates_for_opensuse.html)