Libmspack/Strongswan Update for Arch Linux
Posted on: 02/22/2018 10:09 AM

The following updates has been released for Arch Linux:

ASA-201802-10: strongswan: denial of service
ASA-201802-9: libmspack: multiple issues

ASA-201802-10: strongswan: denial of service
Arch Linux Security Advisory ASA-201802-10
==========================================

Severity: Medium
Date : 2018-02-21
CVE-ID : CVE-2018-6459
Package : strongswan
Type : denial of service
Remote : Yes
Link : https://security.archlinux.org/AVG-625

Summary
=======

The package strongswan before version 5.6.2-1 is vulnerable to denial
of service.

Resolution
==========

Upgrade to 5.6.2-1.

# pacman -Syu "strongswan>=5.6.2-1"

The problem has been fixed upstream in version 5.6.2.

Workaround
==========

None.

Description
===========

The rsa_pss_params_parse function in
libstrongswan/credentials/keys/signature_params.c before strongSwan
5.6.2 allows remote attackers to cause a denial of service via a
crafted RSASSA-PSS signature that lacks a mask generation function
parameter.

Impact
======

A remote attacker is able to crash the application by providing a
maliciously-crafted signature.

References
==========

https://bugs.archlinux.org/task/57597
https://www.strongswan.org/blog/2018/02/19/strongswan-vulnerability-(cve-2018-6459).html
https://download.strongswan.org/security/CVE-2018-6459/strongswan-5.6.1_pss_mgf1_alg.patch
https://github.com/strongswan/strongswan/commit/40da179f28b768ffcf6ff7e2f68675eb44806668
https://security.archlinux.org/CVE-2018-6459



ASA-201802-9: libmspack: multiple issues

Arch Linux Security Advisory ASA-201802-9
=========================================

Severity: Critical
Date : 2018-02-20
CVE-ID : CVE-2017-6419 CVE-2017-11423
Package : libmspack
Type : multiple issues
Remote : Yes
Link : https://security.archlinux.org/AVG-603

Summary
=======

The package libmspack before version 1:0.6alpha-1 is vulnerable to
multiple issues including arbitrary code execution and denial of
service.

Resolution
==========

Upgrade to 1:0.6alpha-1.

# pacman -Syu "libmspack>=1:0.6alpha-1"

The problems have been fixed upstream in version 0.6alpha.

Workaround
==========

None.

Description
===========

- CVE-2017-6419 (arbitrary code execution)

mspack/lzxd.c in libmspack 0.5alpha, as used in ClamAV before 0.99.3,
allows remote attackers to cause a denial of service (heap-based buffer
overflow and application crash) or possibly execute arbitrary code via
a crafted CHM file.

- CVE-2017-11423 (denial of service)

The cabd_read_string function in mspack/cabd.c in libmspack 0.5alpha,
as used in ClamAV before 0.99.3 and other products, allows remote
attackers to cause a denial of service (stack-based buffer over-read
and application crash) via a crafted CAB file.

Impact
======

A remote attacker is able to crash the application or execute arbitrary
code by providing a maliciously-crafted file.

References
==========

https://bugzilla.clamav.net/show_bug.cgi?id=11701
https://github.com/vrtadmin/clamav-devel/commit/a83773682e856ad6529ba6db8d1792e6d515d7f1
https://github.com/kyz/libmspack/commit/6139a0b9e93fcb7fcf423e56aa825bc869e02229
https://bugzilla.clamav.net/show_bug.cgi?id=11873
https://github.com/kyz/libmspack/commit/17038206fcc384dcee6dd9e3a75f08fd3ddc6a38
https://github.com/vrtadmin/clamav-devel/commit/ffa31264a657618a0e40c51c01e4bfc32e244d13
https://github.com/vrtadmin/clamav-devel/commit/ada5f94e5cfb04e1ac2a6f383f2184753f475b96
https://github.com/hackerlib/hackerlib-vul/tree/master/clamav-vul
https://security.archlinux.org/CVE-2017-6419
https://security.archlinux.org/CVE-2017-11423





Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/libmspackstrongswan_update_for_arch_linux.html)