Libjpeg-Turbo, NTP, OpenSLP Updates for Ubuntu
Posted on: 07/10/2018 07:44 AM

The following updates has been released for Ubuntu Linux:

USN-3706-1: libjpeg-turbo vulnerabilities
USN-3707-1: NTP vulnerabilities
USN-3708-1: OpenSLP vulnerabilities

USN-3706-1: libjpeg-turbo vulnerabilities

==========================================================================
Ubuntu Security Notice USN-3706-1
July 09, 2018

libjpeg-turbo vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 18.04 LTS
- Ubuntu 17.10
- Ubuntu 16.04 LTS
- Ubuntu 14.04 LTS

Summary:

libjpeg-turbo could be made to crash or run programs as your login if it
opened a specially crafted file.

Software Description:
- libjpeg-turbo: library for handling JPEG files

Details:

It was discovered that libjpeg-turbo incorrectly handled certain malformed
JPEG images. If a user or automated system were tricked into opening a
specially crafted JPEG image, a remote attacker could cause libjpeg-turbo
to crash, resulting in a denial of service, or possibly execute arbitrary
code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 18.04 LTS:
libjpeg-turbo8 1.5.2-0ubuntu5.18.04.1

Ubuntu 17.10:
libjpeg-turbo8 1.5.2-0ubuntu5.17.10.1

Ubuntu 16.04 LTS:
libjpeg-turbo8 1.4.2-0ubuntu3.1

Ubuntu 14.04 LTS:
libjpeg-turbo8 1.3.0-0ubuntu2.1

In general, a standard system update will make all the necessary changes.

References:
https://usn.ubuntu.com/usn/usn-3706-1
CVE-2014-9092, CVE-2016-3616, CVE-2017-15232, CVE-2018-11212,
CVE-2018-11213, CVE-2018-11214, CVE-2018-1152

Package Information:
https://launchpad.net/ubuntu/+source/libjpeg-turbo/1.5.2-0ubuntu5.18.04.1
https://launchpad.net/ubuntu/+source/libjpeg-turbo/1.5.2-0ubuntu5.17.10.1
https://launchpad.net/ubuntu/+source/libjpeg-turbo/1.4.2-0ubuntu3.1
https://launchpad.net/ubuntu/+source/libjpeg-turbo/1.3.0-0ubuntu2.1


USN-3707-1: NTP vulnerabilities

==========================================================================
Ubuntu Security Notice USN-3707-1
July 09, 2018

ntp vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 18.04 LTS
- Ubuntu 17.10
- Ubuntu 16.04 LTS
- Ubuntu 14.04 LTS

Summary:

Several security issues were fixed in NTP.

Software Description:
- ntp: Network Time Protocol daemon and utility programs

Details:

Yihan Lian discovered that NTP incorrectly handled certain malformed mode 6
packets. A remote attacker could possibly use this issue to cause ntpd to
crash, resulting in a denial of service. This issue only affected Ubuntu
17.10 and Ubuntu 18.04 LTS. (CVE-2018-7182)

Michael Macnair discovered that NTP incorrectly handled certain responses.
A remote attacker could possibly use this issue to execute arbitrary code.
(CVE-2018-7183)

Miroslav Lichvar discovered that NTP incorrectly handled certain
zero-origin timestamps. A remote attacker could possibly use this issue to
cause a denial of service. This issue only affected Ubuntu 17.10 and Ubuntu
18.04 LTS. (CVE-2018-7184)

Miroslav Lichvar discovered that NTP incorrectly handled certain
zero-origin timestamps. A remote attacker could possibly use this issue to
cause a denial of service. (CVE-2018-7185)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 18.04 LTS:
ntp 1:4.2.8p10+dfsg-5ubuntu7.1

Ubuntu 17.10:
ntp 1:4.2.8p10+dfsg-5ubuntu3.3

Ubuntu 16.04 LTS:
ntp 1:4.2.8p4+dfsg-3ubuntu5.9

Ubuntu 14.04 LTS:
ntp 1:4.2.6.p5+dfsg-3ubuntu2.14.04.13

In general, a standard system update will make all the necessary changes.

References:
https://usn.ubuntu.com/usn/usn-3707-1
CVE-2018-7182, CVE-2018-7183, CVE-2018-7184, CVE-2018-7185

Package Information:
https://launchpad.net/ubuntu/+source/ntp/1:4.2.8p10+dfsg-5ubuntu7.1
https://launchpad.net/ubuntu/+source/ntp/1:4.2.8p10+dfsg-5ubuntu3.3
https://launchpad.net/ubuntu/+source/ntp/1:4.2.8p4+dfsg-3ubuntu5.9
https://launchpad.net/ubuntu/+source/ntp/1:4.2.6.p5+dfsg-3ubuntu2.14.04.13


USN-3708-1: OpenSLP vulnerabilities

==========================================================================
Ubuntu Security Notice USN-3708-1
July 09, 2018

openslp-dfsg vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 LTS
- Ubuntu 14.04 LTS

Summary:

OpenSLP could be made to crash or run programs if it received specially
crafted network traffic.

Software Description:
- openslp-dfsg: Service Location Protocol library

Details:

It was discovered that OpenSLP incorrectly handled certain memory
operations. A remote attacker could use this issue to cause OpenSLP to
crash, resulting in a denial of service, or possibly execute arbitrary
code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 LTS:
libslp1 1.2.1-11ubuntu0.16.04.1

Ubuntu 14.04 LTS:
libslp1 1.2.1-9ubuntu0.3

In general, a standard system update will make all the necessary changes.

References:
https://usn.ubuntu.com/usn/usn-3708-1
CVE-2017-17833, CVE-2018-12938

Package Information:
https://launchpad.net/ubuntu/+source/openslp-dfsg/1.2.1-11ubuntu0.16.04.1
https://launchpad.net/ubuntu/+source/openslp-dfsg/1.2.1-9ubuntu0.3





Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/libjpeg_turbontpopenslp_updates_for_ubuntu.html)