Libextractor, Mgetty, Kamailio Updates for Debian
Posted on: 09/12/2018 07:22 AM

The following updates has been released for Debian GNU/Linux:

Debian GNU/Linux 8 LTS:
DLA 1501-1: libextractor security update

Debian GNU/Linux 9:
DSA 4291-1: mgetty security update
DSA 4292-1: kamailio security update

DLA 1501-1: libextractor security update



Package : libextractor
Version : 1:1.3-2+deb8u3
CVE ID : CVE-2018-16430
Debian Bug : #907987

It was discovered that there was an out-of-bounds read vulnerability in
libextractor, a library to extract meta-data from files of arbitrary type.

For Debian 8 "Jessie", this issue has been fixed in libextractor version
1:1.3-2+deb8u3.

We recommend that you upgrade your libextractor packages.





DSA 4291-1: mgetty security update



- -------------------------------------------------------------------------
Debian Security Advisory DSA-4291-1 security@debian.org
https://www.debian.org/security/ Yves-Alexis Perez
September 11, 2018 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : mgetty
CVE ID : CVE-2018-16741

Two input sanitization failures have been found in the faxrunq and faxq
binaries in mgetty, a smart modem getty replacement. An attacker could leverage
them to insert commands via shell metacharacters in jobs id and have them
executed with the privilege of the faxrunq/faxq user.

For the stable distribution (stretch), this problem has been fixed in
version 1.1.36-3+deb9u1.

We recommend that you upgrade your mgetty packages.

For the detailed security status of mgetty please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/mgetty

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/




DSA 4292-1: kamailio security update



- -------------------------------------------------------------------------
Debian Security Advisory DSA-4292-1 security@debian.org
https://www.debian.org/security/ Salvatore Bonaccorso
September 11, 2018 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : kamailio
CVE ID : CVE-2018-16657
Debian Bug : 908324

Henning Westerholt discovered a flaw related to the Via header
processing in kamailio, a very fast, dynamic and configurable SIP
server. An unauthenticated attacker can take advantage of this flaw to
mount a denial of service attack via a specially crafted SIP message
with an invalid Via header.

For the stable distribution (stretch), this problem has been fixed in
version 4.4.4-2+deb9u3.

We recommend that you upgrade your kamailio packages.

For the detailed security status of kamailio please refer to its
security tracker page at:
https://security-tracker.debian.org/tracker/kamailio

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/







Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/libextractormgettykamailio_updates_for_debian.html)