Libarchive and Dovecot Updates for Debian
Posted on: 02/08/2019 08:51 AM

The following updates has been released for Debian GNU/Linux:

Debian GNU/Linux 7 Extended LTS:
ELA-82-1 libarchive security update

Debian GNU/Linux 8 LTS:
DLA 1667-1: dovecot security update
DLA 1668-1: libarchive security update


ELA-82-1 libarchive security update
Package: libarchive
Version: 3.0.4-3+wheezy6+deb7u3
Related CVE: CVE-2019-1000019 CVE-2019-1000020
Two vulnerabilities were discovered and corrected in the libarchive multi-format compression library, first fixing an issue where a specially-crafted .z7ip file could cause a denial-of-service attack via a crash (CVE-2019-1000019) in addition to an endless-loop vulnerability where a malicious ISO9660 image could cause an infinite loop (CVE-2019-1000020).

For Debian 7 Wheezy, these problems have been fixed in version 3.0.4-3+wheezy6+deb7u3.

We recommend that you upgrade your libarchive packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/


DLA 1667-1: dovecot security update



Package : dovecot
Version : 1:2.2.13-12~deb8u5
CVE ID : CVE-2019-3814

It was discovered that there was a vulnerability in the dovecot
IMAP/POP3 server.

A flaw in the TLS username handling could lead to an attacker
logging in as anyone else in the system if both
auth_ssl_{require_client,username_from}_cert were enabled.

For Debian 8 "Jessie", this issue has been fixed in dovecot version
1:2.2.13-12~deb8u5.

We recommend that you upgrade your dovecot packages.





DLA 1668-1: libarchive security update
Package : libarchive
Version : 3.1.2-11+deb8u7
CVE ID : CVE-2019-1000019 CVE-2019-1000020

Fuzzing found two further file-format specific issues in libarchive, a
read-only segfault in 7z, and an infinite loop in ISO9660.

CVE-2019-1000019

Out-of-bounds Read vulnerability in 7zip decompression, that can
result in a crash (denial of service, CWE-125)

CVE-2019-1000020

Vulnerability in ISO9660 parser that can result in DoS by infinite
loop (CWE-835)

For Debian 8 "Jessie", these problems have been fixed in version
3.1.2-11+deb8u7.

We recommend that you upgrade your libarchive packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS






Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/libarchive_and_dovecot_updates_for_debian.html)