leptonica Securiy Update for openSUSE
Posted on: 02/13/2018 09:08 AM

Updated leptonica packages has been released for openSUSE Leap 42.3

leptonica Securiy Update for openSUSE


______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0429-1
Rating: important
References: #1079358
Cross-References: CVE-2018-3836
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for leptonica fixes the following issues:

- CVE-2018-3836: Fixes a command injection vulnerability (boo#1079358
TALOS-2018-0516)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-158=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

leptonica-debugsource-1.72-6.1
leptonica-devel-1.72-6.1
leptonica-tools-1.72-6.1
leptonica-tools-debuginfo-1.72-6.1
liblept4-1.72-6.1
liblept4-debuginfo-1.72-6.1

- openSUSE Leap 42.3 (x86_64):

liblept4-32bit-1.72-6.1
liblept4-debuginfo-32bit-1.72-6.1


References:

https://www.suse.com/security/cve/CVE-2018-3836.html
https://bugzilla.suse.com/1079358



Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/leptonica_securiy_update_for_opensuse.html)