Jekyll and Gnulib Updates for Debian 8 LTS
Posted on: 10/11/2018 07:24 AM

The following updates has been released for Debian GNU/Linux 8 LTS:

DLA 1541-1: jekyll security update
DLA 1543-1: gnulib security update

DLA 1541-1: jekyll security update



Package : jekyll
Version : 2.2.0+dfsg-2+deb8u1
CVE ID : CVE-2018-17567
Debian Bug : 909933


Parker Moore from Github Inc, discovered a vulnerability in include:
setting in the config file of jekyll which allow arbitrary file reads.
By simply including a symlink in the include array allowed the
symlinked file to be read into the build when they shouldn’t actually
be read in any circumstance.

For Debian 8 "Jessie", this problem has been fixed in version
2.2.0+dfsg-2+deb8u1.

We recommend that you upgrade your jekyll packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS



DLA 1543-1: gnulib security update



Package : gnulib
Version : 20140202+stable-2+deb8u1
CVE ID : CVE-2018-17942
Debian Bug : 910757

Ben Pfaff discovered that the convert_to_decimal function in the GNU
Portability Library contains a heap-based buffer overflow because memory
is not allocated for a trailing '\0' character during %f processing.

For Debian 8 "Jessie", this problem has been fixed in version
20140202+stable-2+deb8u1.

We recommend that you upgrade your gnulib packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS






Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/jekyll_and_gnulib_updates_for_debian_8_lts.html)