Java-11-OpenJDK, Enigmail, ClamAV Updates for openSUSE
Posted on: 08/09/2018 06:36 AM

The following updates has been released for openSUSE:

openSUSE-SU-2018:2247-1: moderate: Security update for java-11-openjdk
openSUSE-SU-2018:2251-1: moderate: Recommended update for enigmail
openSUSE-SU-2018:2259-1: moderate: Security update for clamav


openSUSE-SU-2018:2247-1: moderate: Security update for java-11-openjdk
openSUSE Security Update: Security update for java-11-openjdk
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2247-1
Rating: moderate
References: #1101645 #1101651 #1101655 #1101656
Cross-References: CVE-2018-2940 CVE-2018-2952 CVE-2018-2972
CVE-2018-2973
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

This java-11-openjdk update to version jdk-11+24 fixes the following
issues:

Security issues fixed:

- CVE-2018-2940: Fix unspecified vulnerability in subcomponent Libraries
(bsc#1101645).
- CVE-2018-2952: Fix unspecified vulnerability in subcomponent Concurrency
(bsc#1101651).
- CVE-2018-2972: Fix unspecified vulnerability in subcomponent Security
(bsc#1101655).
- CVE-2018-2973: Fix unspecified vulnerability in subcomponent JSSE
(bsc#1101656).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-830=1



Package List:

- openSUSE Leap 15.0 (noarch):

java-11-openjdk-javadoc-11.0.0.0~24-lp150.2.3.2

- openSUSE Leap 15.0 (x86_64):

java-11-openjdk-11.0.0.0~24-lp150.2.3.2
java-11-openjdk-accessibility-11.0.0.0~24-lp150.2.3.2
java-11-openjdk-accessibility-debuginfo-11.0.0.0~24-lp150.2.3.2
java-11-openjdk-debuginfo-11.0.0.0~24-lp150.2.3.2
java-11-openjdk-debugsource-11.0.0.0~24-lp150.2.3.2
java-11-openjdk-demo-11.0.0.0~24-lp150.2.3.2
java-11-openjdk-devel-11.0.0.0~24-lp150.2.3.2
java-11-openjdk-headless-11.0.0.0~24-lp150.2.3.2
java-11-openjdk-jmods-11.0.0.0~24-lp150.2.3.2
java-11-openjdk-src-11.0.0.0~24-lp150.2.3.2


References:

https://www.suse.com/security/cve/CVE-2018-2940.html
https://www.suse.com/security/cve/CVE-2018-2952.html
https://www.suse.com/security/cve/CVE-2018-2972.html
https://www.suse.com/security/cve/CVE-2018-2973.html
https://bugzilla.suse.com/1101645
https://bugzilla.suse.com/1101651
https://bugzilla.suse.com/1101655
https://bugzilla.suse.com/1101656

--



openSUSE-SU-2018:2251-1: moderate: Recommended update for enigmail
openSUSE Security Update: Recommended update for enigmail
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2251-1
Rating: moderate
References: #1104036
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 15.0
______________________________________________________________________________

An update that contains security fixes can now be installed.

Description:

This update for enigmail to 2.0.8 fixes the following issues:

The enigmail 2.0.8 release addresses a security issue and solves a few
regression bugs.

* A security issue has been fixed that allows an attacker to prepare a
plain, unauthenticated HTML message in a way that it looks like it's
signed and/or encrypted (boo#1104036)


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-833=1

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-833=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

enigmail-2.0.8-24.1

- openSUSE Leap 15.0 (x86_64):

enigmail-2.0.8-lp150.2.15.1


References:

https://bugzilla.suse.com/1104036

--



openSUSE-SU-2018:2259-1: moderate: Security update for clamav
openSUSE Security Update: Security update for clamav
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2259-1
Rating: moderate
References: #1101410 #1101412 #1101654 #1103040
Cross-References: CVE-2018-0360 CVE-2018-0361
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves two vulnerabilities and has two fixes
is now available.

Description:

This update for clamav to version 0.100.1 fixes the following issues:

The following security vulnerabilities were addressed:

- CVE-2018-0360: HWP integer overflow, infinite loop vulnerability
(bsc#1101410)
- CVE-2018-0361: PDF object length check, unreasonably long time to parse
relatively small file (bsc#1101412)
- Buffer over-read in unRAR code due to missing max value checks in table
initialization
- Libmspack heap buffer over-read in CHM parser (bsc#1103040)
- PDF parser bugs

The following other changes were made:

- Disable YARA support for licensing reasons (bsc#1101654).
- Add HTTPS support for clamsubmit
- Fix for DNS resolution for users on IPv4-only machines where IPv6 is not
available or is link-local only

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-838=1



Package List:

- openSUSE Leap 15.0 (x86_64):

clamav-0.100.1-lp150.2.3.1
clamav-debuginfo-0.100.1-lp150.2.3.1
clamav-debugsource-0.100.1-lp150.2.3.1
clamav-devel-0.100.1-lp150.2.3.1
libclamav7-0.100.1-lp150.2.3.1
libclamav7-debuginfo-0.100.1-lp150.2.3.1
libclammspack0-0.100.1-lp150.2.3.1
libclammspack0-debuginfo-0.100.1-lp150.2.3.1


References:

https://www.suse.com/security/cve/CVE-2018-0360.html
https://www.suse.com/security/cve/CVE-2018-0361.html
https://bugzilla.suse.com/1101410
https://bugzilla.suse.com/1101412
https://bugzilla.suse.com/1101654
https://bugzilla.suse.com/1103040

--






Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/java_11_openjdkenigmailclamav_updates_for_opensuse.html)