Iproute, Iscsi-Initiator-Utils, UEKR4 Updates for Oracle Linux
Posted on: 02/09/2019 08:53 AM

The following updates has been released for Oracle Linux:

ELBA-2019-4536 Oracle Linux 7 iproute bug fix update
ELBA-2019-4536 Oracle Linux 7 iproute bug fix update (aarch64)
ELBA-2019-4538 Oracle Linux 7 iscsi-initiator-utils bug fix update
New Ksplice updates for UEKR4 4.1.12 on OL6 and OL7 (ELSA-2019-4531)

ELBA-2019-4536 Oracle Linux 7 iproute bug fix update
Oracle Linux Bug Fix Advisory ELBA-2019-4536

http://linux.oracle.com/errata/ELBA-2019-4536.html

The following updated rpms for Oracle Linux 7 have been uploaded to the
Unbreakable Linux Network:

x86_64:
iproute-4.16.0-1.0.1.el7.x86_64.rpm
iproute-devel-4.16.0-1.0.1.el7.x86_64.rpm
iproute-doc-4.16.0-1.0.1.el7.x86_64.rpm
iproute-tc-4.16.0-1.0.1.el7.x86_64.rpm


SRPMS:
http://oss.oracle.com/ol7/SRPMS-updates/iproute-4.16.0-1.0.1.el7.src.rpm



Description of changes:

[4.16.0-1.0.1]
- [Orabug: 28571160]


ELBA-2019-4536 Oracle Linux 7 iproute bug fix update (aarch64)
Oracle Linux Bug Fix Advisory ELBA-2019-4536

http://linux.oracle.com/errata/ELBA-2019-4536.html

The following updated rpms for Oracle Linux 7 have been uploaded to the
Unbreakable Linux Network:

aarch64:
iproute-4.16.0-1.0.1.el7.aarch64.rpm
iproute-tc-4.16.0-1.0.1.el7.aarch64.rpm
iproute-devel-4.16.0-1.0.1.el7.aarch64.rpm
iproute-doc-4.16.0-1.0.1.el7.aarch64.rpm


SRPMS:
http://oss.oracle.com/ol7/SRPMS-updates/iproute-4.16.0-1.0.1.el7.src.rpm



Description of changes:

[4.16.0-1.0.1]
- [Orabug: 28571160]

[4.16.0-1]
- update to v4.16.0


ELBA-2019-4538 Oracle Linux 7 iscsi-initiator-utils bug fix update
Oracle Linux Bug Fix Advisory ELBA-2019-4538

http://linux.oracle.com/errata/ELBA-2019-4538.html

The following updated rpms for Oracle Linux 7 have been uploaded to the
Unbreakable Linux Network:

x86_64:
iscsi-initiator-utils-6.2.0.874-10.0.5.el7.i686.rpm
iscsi-initiator-utils-6.2.0.874-10.0.5.el7.x86_64.rpm
iscsi-initiator-utils-iscsiuio-6.2.0.874-10.0.5.el7.x86_64.rpm
iscsi-initiator-utils-devel-6.2.0.874-10.0.5.el7.i686.rpm
iscsi-initiator-utils-devel-6.2.0.874-10.0.5.el7.x86_64.rpm


SRPMS:
http://oss.oracle.com/ol7/SRPMS-updates/iscsi-initiator-utils-6.2.0.874-10.0.5.el7.src.rpm



Description of changes:

[6.2.0.874-10.0.5]
- Add 0203-Update-systemd-to-always-restart-iscsid-service.patch to fix
[Orabug: 29306329]


New Ksplice updates for UEKR4 4.1.12 on OL6 and OL7 (ELSA-2019-4531)
Synopsis: ELSA-2019-4531 can now be patched using Ksplice
CVEs: CVE-2017-12153 CVE-2018-17972

Users with Oracle Linux Premier Support can now use Ksplice to patch
against the latest Oracle Linux Security Advisory, ELSA-2019-4531.

INSTALLING THE UPDATES

We recommend that all users of Ksplice Uptrack running UEKR4 4.1.12 on
OL6 and OL7 install these updates.

On systems that have "autoinstall = yes" in /etc/uptrack/uptrack.conf,
these updates will be installed automatically and you do not need to
take any action.

Alternatively, you can install these updates by running:

# /usr/sbin/uptrack-upgrade -y


DESCRIPTION

* CVE-2017-12153: Denial-of-service when using cfg80211 wireless extension with GTK rekey offload.

A missing check when using GTK rekey offload, during a WoWLAN for
example, in cfg80211 wireless extension could lead to a NULL pointer
dereference. A local attacker with CAP_NET_ADMIN capability could use this
flaw to cause a denial-of-service.

Orabug: 29245533


* CVE-2018-17972: Information leak in kernel stack dumps in /proc.

A missing permissions check in the proc code could allow an unprivileged
user to access the kernel stack memory space.

Orabug: 29114879

SUPPORT

Ksplice support is available at ksplice-support_ww@oracle.com.






Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/iprouteiscsi_initiator_utilsuekr4_updates_for_oracle_linux.html)