Go and util-linux updates for Gentoo Linux
Posted on: 03/08/2018 09:35 AM

The following two updates has been released for Gentoo Linux:

GLSA 201803-02 : util-linux: User-assisted execution of arbitrary code
GLSA 201803-03 : Go: User-assisted execution of arbitrary code

GLSA 201803-02 : util-linux: User-assisted execution of arbitrary code

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201803-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: util-linux: User-assisted execution of arbitrary code
Date: March 07, 2018
Bugs: #649812
ID: 201803-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability was discovered in util-linux, which could potentially
lead to the execution of arbitrary code.

Background
==========

util-linux is a suite of Linux programs including mount and umount,
programs used to mount and unmount filesystems.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 sys-apps/util-linux < 2.30.2-r1 >= 2.30.2-r1

Description
===========

It was discovered that the umount bash-completion as provided by
util-linux does not escap mount point paths.

Impact
======

An attacker controlling a volume label could entice a user with
privileges to mount/umount filesystems to use umount command with auto
completion, possibly resulting in execution of arbitrary code with root
privileges.

Workaround
==========

Disable Bash-completion or remove
"/usr/share/bash-completion/completions/umount".

Resolution
==========

All util-linux users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=sys-apps/util-linux-2.30.2-r1"

References
==========

[ 1 ] CVE-2018-7738
https://nvd.nist.gov/vuln/detail/CVE-2018-7738

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201803-02

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5


GLSA 201803-03 : Go: User-assisted execution of arbitrary code

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201803-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: Go: User-assisted execution of arbitrary code
Date: March 07, 2018
Bugs: #647250
ID: 201803-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in Go might allow remote attackers to execute arbitrary
commands during source code build.

Background
==========

Go is an open source programming language that makes it easy to build
simple, reliable, and efficient software.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-lang/go < 1.9.4 >= 1.9.4

Description
===========

A command injection flaw was discovered in the source code build phase
because of the "go get" command, which does not block -fplugin= and
-plugin arguments.

Impact
======

A remote attacker could entice a user to process a repository
containing maliciously-crafted build instructions using "go get",
resulting in the execution of arbitrary code with the privileges of the
process.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Go users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/go-1.9.4"

References
==========

[ 1 ] CVE-2018-6574
https://nvd.nist.gov/vuln/detail/CVE-2018-6574

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201803-03

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5




Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/go_and_util_linux_updates_for_gentoo_linux.html)