GnuTLS, libTIFF, phpMyAdmin Updates for Gentoo Linux
Posted on: 04/16/2019 06:55 AM

The following updates has been released for Gentoo Linux:

GLSA 201904-14 : GnuTLS: Multiple vulnerabilities
GLSA 201904-15 : libTIFF: Denial of Service
GLSA 201904-16 : phpMyAdmin: Multiple vulnerabilities

GLSA 201904-14 : GnuTLS: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201904-14
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: GnuTLS: Multiple vulnerabilities
Date: April 15, 2019
Bugs: #681846
ID: 201904-14

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in GnuTLS, the worst of which
could result in a Denial of Service condition.

Background
==========

GnuTLS is a secure communications library implementing the SSL, TLS and
DTLS protocols and technologies around them.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-libs/gnutls < 3.6.7 >= 3.6.7

Description
===========

Multiple vulnerabilities have been discovered in GnuTLS. Please review
the CVE identifiers referenced below for details.

Impact
======

Please review the CVE identifiers referenced below for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GnuTLS users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-libs/gnutls-3.6.7"

References
==========

[ 1 ] CVE-2019-3829
https://nvd.nist.gov/vuln/detail/CVE-2019-3829
[ 2 ] CVE-2019-3836
https://nvd.nist.gov/vuln/detail/CVE-2019-3836

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201904-14

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2019 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5




GLSA 201904-15 : libTIFF: Denial of Service
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201904-15
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: libTIFF: Denial of Service
Date: April 15, 2019
Bugs: #669948
ID: 201904-15

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in libTIFF could lead to a Denial of Service condition.

Background
==========

The TIFF library contains encoding and decoding routines for the Tag
Image File Format. It is called by numerous programs, including GNOME
and KDE applications, to interpret TIFF images.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-libs/tiff < 4.0.10 >= 4.0.10

Description
===========

Please review the CVE identifier referenced below for details.

Impact
======

Please review the CVE identifier referenced below for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All tiff users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/tiff-4.0.10"

References
==========

[ 1 ] CVE-2018-18557
https://nvd.nist.gov/vuln/detail/CVE-2018-18557

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201904-15

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2019 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5




GLSA 201904-16 : phpMyAdmin: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201904-16
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: phpMyAdmin: Multiple vulnerabilities
Date: April 15, 2019
Bugs: #658742, #672938
ID: 201904-16

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in phpMyAdmin, the worst of
which could result in the arbitrary execution of code.

Background
==========

phpMyAdmin is a web-based management tool for MySQL databases.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-db/phpmyadmin < 4.8.4 >= 4.8.4

Description
===========

Multiple vulnerabilities have been discovered in phpMyAdmin. Please
review the CVE identifiers referenced below for details.

Impact
======

Please review the CVE identifiers referenced below for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All phpMyAdmin users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/phpmyadmin-4.8.4"

References
==========

[ 1 ] CVE-2018-12613
https://nvd.nist.gov/vuln/detail/CVE-2018-12613
[ 2 ] CVE-2018-19968
https://nvd.nist.gov/vuln/detail/CVE-2018-19968
[ 3 ] CVE-2018-19969
https://nvd.nist.gov/vuln/detail/CVE-2018-19969
[ 4 ] CVE-2018-19970
https://nvd.nist.gov/vuln/detail/CVE-2018-19970

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201904-16

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2019 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5







Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/gnutlslibtiffphpmyadmin_updates_for_gentoo_linux.html)