Glibc/P7Zip Updates for openSUSE
Posted on: 02/21/2018 10:32 AM

The following updates has been released for openSUSE:

openSUSE-SU-2018:0494-1: important: Security update for glibc
openSUSE-SU-2018:0497-1: important: Security update for p7zip

openSUSE-SU-2018:0494-1: important: Security update for glibc
openSUSE Security Update: Security update for glibc
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0494-1
Rating: important
References: #1037930 #1051791 #1073990 #1074293 #1079036

Cross-References: CVE-2017-12132 CVE-2017-8804 CVE-2018-1000001
CVE-2018-6485 CVE-2018-6551
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available.

Description:

This update for glibc fixes the following issues:

Security issues fixed:

- CVE-2017-8804: Fix memory leak after deserialization failure in
xdr_bytes, xdr_string (bsc#1037930)
- CVE-2017-12132: Reduce EDNS payload size to 1200 bytes (bsc#1051791)
- CVE-2018-6485,CVE-2018-6551: Fix integer overflows in internal memalign
and malloc functions (bsc#1079036)
- CVE-2018-1000001: Avoid underflow of malloced area (bsc#1074293)

Non security bugs fixed:

- Release read lock after resetting timeout (bsc#1073990)

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-184=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 i686 x86_64):

glibc-2.22-13.2
glibc-debuginfo-2.22-13.2
glibc-debugsource-2.22-13.2
glibc-devel-2.22-13.2
glibc-devel-debuginfo-2.22-13.2
glibc-devel-static-2.22-13.2
glibc-locale-2.22-13.2
glibc-locale-debuginfo-2.22-13.2
glibc-profile-2.22-13.2

- openSUSE Leap 42.3 (i586 x86_64):

glibc-extra-2.22-13.2
glibc-extra-debuginfo-2.22-13.2
glibc-utils-2.22-13.2
glibc-utils-debuginfo-2.22-13.2
glibc-utils-debugsource-2.22-13.2
nscd-2.22-13.2
nscd-debuginfo-2.22-13.2

- openSUSE Leap 42.3 (noarch):

glibc-html-2.22-13.2
glibc-i18ndata-2.22-13.2
glibc-info-2.22-13.2

- openSUSE Leap 42.3 (x86_64):

glibc-32bit-2.22-13.2
glibc-debuginfo-32bit-2.22-13.2
glibc-devel-32bit-2.22-13.2
glibc-devel-debuginfo-32bit-2.22-13.2
glibc-devel-static-32bit-2.22-13.2
glibc-locale-32bit-2.22-13.2
glibc-locale-debuginfo-32bit-2.22-13.2
glibc-profile-32bit-2.22-13.2
glibc-utils-32bit-2.22-13.2
glibc-utils-debuginfo-32bit-2.22-13.2

- openSUSE Leap 42.3 (i586):

glibc-obsolete-2.22-13.2
glibc-obsolete-debuginfo-2.22-13.2


References:

https://www.suse.com/security/cve/CVE-2017-12132.html
https://www.suse.com/security/cve/CVE-2017-8804.html
https://www.suse.com/security/cve/CVE-2018-1000001.html
https://www.suse.com/security/cve/CVE-2018-6485.html
https://www.suse.com/security/cve/CVE-2018-6551.html
https://bugzilla.suse.com/1037930
https://bugzilla.suse.com/1051791
https://bugzilla.suse.com/1073990
https://bugzilla.suse.com/1074293
https://bugzilla.suse.com/1079036

--



openSUSE-SU-2018:0497-1: important: Security update for p7zip
openSUSE Security Update: Security update for p7zip
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0497-1
Rating: important
References: #1077724 #1077725 #1077978 #984650
Cross-References: CVE-2016-1372 CVE-2017-17969 CVE-2018-5996

Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves three vulnerabilities and has one
errata is now available.

Description:

This update for p7zip fixes the following security issues:

- CVE-2016-1372: Fixed multiple vulnerabilities when processing crafted 7z
files (bsc#984650)
- CVE-2017-17969: Fixed a heap-based buffer overflow in a shrink decoder
(bsc#1077725)
- CVE-2018-5996: Fixed memory corruption in RAR decompression. The
complete RAR decoder was removed as it also has license issues
(bsc#1077724 bsc#1077978)

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-188=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

p7zip-9.20.1-18.3.1
p7zip-debuginfo-9.20.1-18.3.1
p7zip-debugsource-9.20.1-18.3.1


References:

https://www.suse.com/security/cve/CVE-2016-1372.html
https://www.suse.com/security/cve/CVE-2017-17969.html
https://www.suse.com/security/cve/CVE-2018-5996.html
https://bugzilla.suse.com/1077724
https://bugzilla.suse.com/1077725
https://bugzilla.suse.com/1077978
https://bugzilla.suse.com/984650

--






Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/glibcp7zip_updates_for_opensuse.html)