Ghostscript, Evince, Atril Updates for Debian 8 LTS
Posted on: 08/13/2019 02:16 PM

The following security updates has been released for Debian GNU/Linux 8 LTS:

DLA 1880-1: ghostscript security update
DLA 1881-1: evince security update
DLA 1882-1: atril security update

DLA 1880-1: ghostscript security update
Package : ghostscript
Version : 9.26a~dfsg-0+deb8u4
CVE ID : CVE-2019-10216
Debian Bug : 934638

Netanel reported that the .buildfont1 procedure in Ghostscript, the GPL
PostScript/PDF interpreter, does not properly restrict privileged calls,
which could result in bypass of file system restrictions of the dSAFER
sandbox.

For Debian 8 "Jessie", this problem has been fixed in version
9.26a~dfsg-0+deb8u4.

We recommend that you upgrade your ghostscript packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


DLA 1881-1: evince security update
Package : evince
Version : 3.14.1-2+deb8u3
CVE ID : CVE-2017-1000159 CVE-2019-11459 CVE-2019-1010006

A few issues were found in the Evince document viewer.

CVE-2017-1000159

When printing from DVI to PDF, the dvipdfm tool was called without
properly sanitizing the filename, which could lead to a command
injection attack via the filename.

CVE-2019-11459

The tiff_document_render() and tiff_document_get_thumbnail() did
not check the status of TIFFReadRGBAImageOriented(), leading to
uninitialized memory access if that funcion fails.

CVE-2019-1010006

Some buffer overflow checks were not properly done, leading to
application crash or possibly arbitrary code execution when
opening maliciously crafted files.

For Debian 8 "Jessie", these problems have been fixed in version
3.14.1-2+deb8u3.

We recommend that you upgrade your evince packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


DLA 1882-1: atril security update
Package : atril
Version : 1.8.1+dfsg1-4+deb8u2
CVE ID : CVE-2017-1000159 CVE-2019-11459 CVE-2019-1010006

A few issues were found in Atril, the MATE document viewer.

CVE-2017-1000159

When printing from DVI to PDF, the dvipdfm tool was called without
properly sanitizing the filename, which could lead to a command
injection attack via the filename.

CVE-2019-11459

The tiff_document_render() and tiff_document_get_thumbnail() did
not check the status of TIFFReadRGBAImageOriented(), leading to
uninitialized memory access if that funcion fails.

CVE-2019-1010006

Some buffer overflow checks were not properly done, leading to
application crash or possibly arbitrary code execution when
opening maliciously crafted files.

For Debian 8 "Jessie", these problems have been fixed in version
1.8.1+dfsg1-4+deb8u2.

We recommend that you upgrade your atril packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS





Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/ghostscriptevinceatril_updates_for_debian_8_lts.html)