GCC Bug Fix Update for Oracle Linux 7
Posted on: 02/16/2018 06:47 PM

Updated GCC packages has been released for Oracle Linux 7

GCC Bug Fix Update for Oracle Linux 7


Oracle Linux Bug Fix Advisory ELBA-2018-4033

http://linux.oracle.com/errata/ELBA-2018-4033.html

The following updated rpms for Oracle Linux 7 have been uploaded to the
Unbreakable Linux Network:

x86_64:
cpp-4.8.5-16.0.1.el7_4.1.x86_64.rpm
gcc-4.8.5-16.0.1.el7_4.1.x86_64.rpm
gcc-c++-4.8.5-16.0.1.el7_4.1.x86_64.rpm
gcc-gfortran-4.8.5-16.0.1.el7_4.1.x86_64.rpm
gcc-gnat-4.8.5-16.0.1.el7_4.1.x86_64.rpm
gcc-objc-4.8.5-16.0.1.el7_4.1.x86_64.rpm
gcc-objc++-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libatomic-4.8.5-16.0.1.el7_4.1.i686.rpm
libatomic-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libatomic-static-4.8.5-16.0.1.el7_4.1.i686.rpm
libatomic-static-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libgcc-4.8.5-16.0.1.el7_4.1.i686.rpm
libgcc-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libgfortran-4.8.5-16.0.1.el7_4.1.i686.rpm
libgfortran-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libgnat-4.8.5-16.0.1.el7_4.1.i686.rpm
libgnat-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libgnat-devel-4.8.5-16.0.1.el7_4.1.i686.rpm
libgnat-devel-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libgomp-4.8.5-16.0.1.el7_4.1.i686.rpm
libgomp-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libitm-4.8.5-16.0.1.el7_4.1.i686.rpm
libitm-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libitm-devel-4.8.5-16.0.1.el7_4.1.i686.rpm
libitm-devel-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libobjc-4.8.5-16.0.1.el7_4.1.i686.rpm
libobjc-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libquadmath-4.8.5-16.0.1.el7_4.1.i686.rpm
libquadmath-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libquadmath-devel-4.8.5-16.0.1.el7_4.1.i686.rpm
libquadmath-devel-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libstdc++-4.8.5-16.0.1.el7_4.1.i686.rpm
libstdc++-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libstdc++-devel-4.8.5-16.0.1.el7_4.1.i686.rpm
libstdc++-devel-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libstdc++-docs-4.8.5-16.0.1.el7_4.1.x86_64.rpm
gcc-go-4.8.5-16.0.1.el7_4.1.x86_64.rpm
gcc-plugin-devel-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libasan-4.8.5-16.0.1.el7_4.1.i686.rpm
libasan-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libasan-static-4.8.5-16.0.1.el7_4.1.i686.rpm
libasan-static-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libgfortran-static-4.8.5-16.0.1.el7_4.1.i686.rpm
libgfortran-static-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libgnat-static-4.8.5-16.0.1.el7_4.1.i686.rpm
libgnat-static-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libgo-4.8.5-16.0.1.el7_4.1.i686.rpm
libgo-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libgo-devel-4.8.5-16.0.1.el7_4.1.i686.rpm
libgo-devel-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libgo-static-4.8.5-16.0.1.el7_4.1.i686.rpm
libgo-static-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libitm-static-4.8.5-16.0.1.el7_4.1.i686.rpm
libitm-static-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libmudflap-4.8.5-16.0.1.el7_4.1.i686.rpm
libmudflap-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libmudflap-devel-4.8.5-16.0.1.el7_4.1.i686.rpm
libmudflap-devel-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libmudflap-static-4.8.5-16.0.1.el7_4.1.i686.rpm
libmudflap-static-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libquadmath-static-4.8.5-16.0.1.el7_4.1.i686.rpm
libquadmath-static-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libstdc++-static-4.8.5-16.0.1.el7_4.1.i686.rpm
libstdc++-static-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libtsan-4.8.5-16.0.1.el7_4.1.x86_64.rpm
libtsan-static-4.8.5-16.0.1.el7_4.1.x86_64.rpm


SRPMS:
http://oss.oracle.com/ol7/SRPMS-updates/gcc-4.8.5-16.0.1.el7_4.1.src.rpm



Description of changes:

[4.8.5-16.0.1.el7_4.1]
- [Orabug: 27524661]
- Support for retpolines as a mitigation for CVE-2017-5715 aka
variant-2 in x86 targets.



Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/gcc_bug_fix_update_for_oracle_linux_7.html)