Freetype2 Security Update for openSUSE
Posted on: 02/12/2018 02:01 PM

Updated freetype2 packages has been released for openSUSE Leap 42.3

Freetype2 Security Update for openSUSE


______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0420-1
Rating: important
References: #1028103 #1035807 #1036457 #1079600
Cross-References: CVE-2016-10244 CVE-2017-7864 CVE-2017-8105
CVE-2017-8287
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

This update for freetype2 fixes the following security issues:

- CVE-2016-10244: Make sure that the parse_charstrings function in
type1/t1load.c does ensure that a font contains a glyph name to prevent
a DoS through a heap-based buffer over-read or possibly have unspecified
other impact via a crafted file (bsc#1028103)
- CVE-2017-8105: Fix an out-of-bounds write caused by a heap-based buffer
overflow related to the t1_decoder_parse_charstrings function in
psaux/t1decode.ca (bsc#1035807)
- CVE-2017-8287: an out-of-bounds write caused by a heap-based buffer
overflow related to the t1_builder_close_contour function in
psaux/psobjs.c (bsc#1036457)
- Fix several integer overflow issues in truetype/ttinterp.c (bsc#1079600)

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-156=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

freetype2-debugsource-2.6.3-5.3.1
freetype2-devel-2.6.3-5.3.1
ft2demos-2.6.3-5.3.1
libfreetype6-2.6.3-5.3.1
libfreetype6-debuginfo-2.6.3-5.3.1

- openSUSE Leap 42.3 (x86_64):

freetype2-devel-32bit-2.6.3-5.3.1
libfreetype6-32bit-2.6.3-5.3.1
libfreetype6-debuginfo-32bit-2.6.3-5.3.1


References:

https://www.suse.com/security/cve/CVE-2016-10244.html
https://www.suse.com/security/cve/CVE-2017-7864.html
https://www.suse.com/security/cve/CVE-2017-8105.html
https://www.suse.com/security/cve/CVE-2017-8287.html
https://bugzilla.suse.com/1028103
https://bugzilla.suse.com/1035807
https://bugzilla.suse.com/1036457
https://bugzilla.suse.com/1079600



Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/freetype2_security_update_for_opensuse.html)