Firefox-ESR/GCab Packages for Debian
Posted on: 01/25/2018 08:48 AM

The following updates has been released for Debian GNU/Linux

Debian GNU/Linux 7 LTS:
DLA 1256-1: firefox-esr security update

Debian GNU/Linux 8 and 9:
DSA 4096-1: firefox-esr security update

Debian GNU/Linux 9:
DSA 4095-1: gcab security update

DLA 1256-1: firefox-esr security update



Package : firefox-esr
Version : 52.6.0esr-1~deb7u1
CVE ID : CVE-2018-5089 CVE-2018-5091 CVE-2018-5095 CVE-2018-5096
CVE-2018-5097 CVE-2018-5098 CVE-2018-5099 CVE-2018-5102
CVE-2018-5103 CVE-2018-5104 CVE-2018-5117

Several security issues have been found in the Mozilla Firefox web
browser: Multiple memory safety errors, use-after-frees and other
implementation errors may lead to the execution of arbitrary code or denial
of service.

For Debian 7 "Wheezy", these problems have been fixed in version
52.6.0esr-1~deb7u1.

We recommend that you upgrade your firefox-esr packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS



DSA 4095-1: gcab security update



- -------------------------------------------------------------------------
Debian Security Advisory DSA-4095-1 security@debian.org
https://www.debian.org/security/ Salvatore Bonaccorso
January 24, 2018 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : gcab
CVE ID : CVE-2018-5345
Debian Bug : 887776

It was discovered that gcab, a Microsoft Cabinet file manipulation tool,
is prone to a stack-based buffer overflow vulnerability when extracting
.cab files. An attacker can take advantage of this flaw to cause a
denial-of-service or, potentially the execution of arbitrary code with
the privileges of the user running gcab, if a specially crafted .cab
file is processed.

For the stable distribution (stretch), this problem has been fixed in
version 0.7-2+deb9u1.

We recommend that you upgrade your gcab packages.

For the detailed security status of gcab please refer to its security
tracker page at:
https://security-tracker.debian.org/tracker/gcab

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/




DSA 4096-1: firefox-esr security update



- -------------------------------------------------------------------------
Debian Security Advisory DSA-4096-1 security@debian.org
https://www.debian.org/security/ Moritz Muehlenhoff
January 25, 2018 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : firefox-esr
CVE ID : CVE-2018-5089 CVE-2018-5091 CVE-2018-5095 CVE-2018-5096
CVE-2018-5097 CVE-2018-5098 CVE-2018-5099 CVE-2018-5102
CVE-2018-5103 CVE-2018-5104 CVE-2018-5117

Several security issues have been found in the Mozilla Firefox web
browser: Multiple memory safety errors, use-after-frees, integer
overflows and other implementation errors may lead to the execution of
arbitrary code, denial of service or URL spoofing.

For the oldstable distribution (jessie), these problems have been fixed
in version 52.6.0esr-1~deb8u1.

For the stable distribution (stretch), these problems have been fixed in
version 52.6.0esr-1~deb9u1.

We recommend that you upgrade your firefox-esr packages.

For the detailed security status of firefox-esr please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/firefox-esr

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/







Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/firefox_esrgcab_packages_for_debian.html)