File and PNP4Nagios Updates for Gentoo Linux
Posted on: 06/24/2018 08:34 AM

The following updates has been released for Gentoo Linux:

GLSA 201806-08 : file: Denial of service
A remote attacker could send a specially crafted ELF file possibly resulting in a Denial of Service condition

GLSA 201806-09 : PNP4Nagios: Root privilege escalation
It was found that PHP4Nagios creates files owned by an unprivileged user that are used by root

GLSA 201806-08 : file: Denial of service
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201806-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: file: Denial of service
Date: June 23, 2018
Bugs: #657930
ID: 201806-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in file could lead to a Denial of Service condition.

Background
==========

file is a utility that guesses a file format by scanning binary data
for patterns.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 sys-apps/file < 5.33-r2 >= 5.33-r2

Description
===========

File does not properly utilize the do_core_note function in readelf.c
in libmagic.a.

Impact
======

A remote attacker could send a specially crafted ELF file possibly
resulting in a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All file users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=sys-apps/file-5.33-r2"

References
==========

[ 1 ] CVE-2018-10360
https://nvd.nist.gov/vuln/detail/CVE-2018-10360

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201806-08

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5



GLSA 201806-09 : PNP4Nagios: Root privilege escalation
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201806-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: PNP4Nagios: Root privilege escalation
Date: June 24, 2018
Bugs: #637640
ID: 201806-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in PNP4Nagios which may allow local attackers to gain
root privileges.

Background
==========

PNP4Nagios is an addon for the Nagios Network Monitoring System.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-analyzer/pnp4nagios < 0.6.26-r9 >= 0.6.26-r9

Description
===========

It was found that PHP4Nagios creates files owned by an unprivileged
user that are used by root.

Impact
======

A local attacker could escalate privileges to root.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PNP4Nagios users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot -v ">=net-analyzer/pnp4nagios-0.6.26-r9"

References
==========

[ 1 ] CVE-2017-16834
https://nvd.nist.gov/vuln/detail/CVE-2017-16834

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201806-09

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5






Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/file_and_pnp4nagios_updates_for_gentoo_linux.html)