Curl, Libvorbis, openSUSE Leap15.0 Testing Updates
Posted on: 05/19/2018 08:01 AM

The following updates has been released for openSUSE:

openSUSE-SU-2018:1340-1: moderate: Security update for testing the software stack
openSUSE-SU-2018:1344-1: moderate: Security update for curl
openSUSE-SU-2018:1345-1: moderate: Security update for libvorbis

openSUSE-SU-2018:1340-1: moderate: Security update for testing the software stack
openSUSE Security Update: Security update for testing the software stack
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1340-1
Rating: moderate
References:
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that contains security fixes can now be installed.

Description:

This update contains a security update for testing the software stack.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-428=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

update-test-security-5.1-lp150.3.4.2


References:


--



openSUSE-SU-2018:1344-1: moderate: Security update for curl
openSUSE Security Update: Security update for curl
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1344-1
Rating: moderate
References: #1086825 #1092098
Cross-References: CVE-2018-1000301
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for curl fixes several issues:

Security issues fixed:

- CVE-2018-1000301: Fixed a RTSP bad headers buffer over-read could crash
the curl client (bsc#1092098)

Non security issues fixed:

- If the DEFAULT_SUSE cipher list is not available use the HIGH cipher
alias before failing. (bsc#1086825)

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-471=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

curl-7.37.0-36.1
curl-debuginfo-7.37.0-36.1
curl-debugsource-7.37.0-36.1
libcurl-devel-7.37.0-36.1
libcurl4-7.37.0-36.1
libcurl4-debuginfo-7.37.0-36.1

- openSUSE Leap 42.3 (x86_64):

libcurl-devel-32bit-7.37.0-36.1
libcurl4-32bit-7.37.0-36.1
libcurl4-debuginfo-32bit-7.37.0-36.1


References:

https://www.suse.com/security/cve/CVE-2018-1000301.html
https://bugzilla.suse.com/1086825
https://bugzilla.suse.com/1092098

--



openSUSE-SU-2018:1345-1: moderate: Security update for libvorbis
openSUSE Security Update: Security update for libvorbis
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1345-1
Rating: moderate
References: #1059812 #1091072
Cross-References: CVE-2017-14160 CVE-2018-10393
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for libvorbis fixes the following issues:

Security issues fixed:

- CVE-2018-10393: Fixed stack-based buffer over-read in bark_noise_hybridm
(bsc#1091072).
- CVE-2017-14160: Fixed out-of-bounds access inside bark_noise_hybridmp
function (bsc#1059812).

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-472=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

libvorbis-debugsource-1.3.3-14.1
libvorbis-devel-1.3.3-14.1
libvorbis0-1.3.3-14.1
libvorbis0-debuginfo-1.3.3-14.1
libvorbisenc2-1.3.3-14.1
libvorbisenc2-debuginfo-1.3.3-14.1
libvorbisfile3-1.3.3-14.1
libvorbisfile3-debuginfo-1.3.3-14.1

- openSUSE Leap 42.3 (noarch):

libvorbis-doc-1.3.3-14.1

- openSUSE Leap 42.3 (x86_64):

libvorbis0-32bit-1.3.3-14.1
libvorbis0-debuginfo-32bit-1.3.3-14.1
libvorbisenc2-32bit-1.3.3-14.1
libvorbisenc2-debuginfo-32bit-1.3.3-14.1
libvorbisfile3-32bit-1.3.3-14.1
libvorbisfile3-debuginfo-32bit-1.3.3-14.1


References:

https://www.suse.com/security/cve/CVE-2017-14160.html
https://www.suse.com/security/cve/CVE-2018-10393.html
https://bugzilla.suse.com/1059812
https://bugzilla.suse.com/1091072

--






Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/curllibvorbisopensuse_leap15_testing_updates.html)