cURL, Chromium, Transmission Updates for Gentoo Linux
Posted on: 06/20/2018 07:29 AM

The following security updates are available for Gentoo Linux:

GLSA 201806-05 : cURL: Multiple vulnerabilities
Multiple vulnerabilities have been found in cURL, the worst of which could result in a Denial of Service condition.

GLSA 201806-06 : Chromium, Google Chrome: User-assisted execution of arbitrary code
A vulnerablity has been found in Chromium and Chrome that could allow a remote attacker to execute arbitrary code.

GLSA 201806-07 : Transmission: Remote code execution
A vulnerability was discovered in how Transmission handles access control through the X-Transmission-Session-Id.

GLSA 201806-05 : cURL: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201806-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: cURL: Multiple vulnerabilities
Date: June 19, 2018
Bugs: #655266
ID: 201806-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in cURL, the worst of which
could result in a Denial of Service condition.

Background
==========

A command line tool and library for transferring data with URLs.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-misc/curl < 7.60.0 >= 7.60.0

Description
===========

Multiple vulnerabilities have been discovered in cURL. Please review
the CVE identifiers referenced below for details.

Impact
======

Remote attackers could cause a Denial of Service condition, obtain
sensitive information, or have other unspecified impacts.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All cURL users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/curl-7.60.0"

References
==========

[ 1 ] CVE-2018-1000300
https://nvd.nist.gov/vuln/detail/CVE-2018-1000300
[ 2 ] CVE-2018-1000301
https://nvd.nist.gov/vuln/detail/CVE-2018-1000301

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201806-05

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5



GLSA 201806-06 : Chromium, Google Chrome: User-assisted execution of arbitrary code
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201806-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Chromium, Google Chrome: User-assisted execution of arbitrary
code
Date: June 20, 2018
Bugs: #658040
ID: 201806-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerablity has been found in Chromium and Chrome that could allow a
remote attacker to execute arbitrary code.

Background
==========

Chromium is an open-source browser project that aims to build a safer,
faster, and more stable way for all users to experience the web.

Google Chrome is one fast, simple, and secure browser for all your
devices.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 www-client/chromium < 67.0.3396.87 >= 67.0.3396.87
2 www-client/chrome < 67.0.3396.87 >= 67.0.3396.87
-------------------------------------------------------------------
2 affected packages

Description
===========

An out of bounds flaw has discovered in Chromium and Chrome's V8
component.

Impact
======

A remote attacker, by enticing a user to visit a specially crafted
website, could execute arbitrary code with the privileges of the
process

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Chromium users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot -v ">=www-client/chromium-67.0.3396.87"

All Chrome users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/chrome-67.0.3396.87"

References
==========

[ 1 ] CVE-2018-6149
https://nvd.nist.gov/vuln/detail/CVE-2018-6149

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201806-06

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5



GLSA 201806-07 : Transmission: Remote code execution
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201806-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Transmission: Remote code execution
Date: June 20, 2018
Bugs: #644406
ID: 201806-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in Transmission could allow a remote attacker to
execute arbitrary RPC commands.

Background
==========

Transmission is a cross-platform BitTorrent client.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-p2p/transmission < 2.93 >= 2.93

Description
===========

A vulnerability was discovered in how Transmission handles access
control through the X-Transmission-Session-Id.

Impact
======

A remote attacker could execute arbitrary RFC commands or consequently
conduct a DNS rebinding attack.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Transmission users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-p2p/transmission-"

References
==========

[ 1 ] CVE-2018-5702
https://nvd.nist.gov/vuln/detail/CVE-2018-5702

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201806-07

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5






Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/curlchromiumtransmission_updates_for_gentoo_linux.html)