CouchDB, SpamAssassin, Scala Updates for Gentoo Linux
Posted on: 12/16/2018 10:40 AM

The following updates has been released for Gentoo Linux:

GLSA 201812-06 : CouchDB: Multiple vulnerabilities
GLSA 201812-07 : SpamAssassin: Multiple vulnerabilities
GLSA 201812-08 : Scala: Privilege escalation

GLSA 201812-06 : CouchDB: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201812-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: CouchDB: Multiple vulnerabilities
Date: December 15, 2018
Bugs: #630796, #660908, #663164
ID: 201812-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in CouchDB, the worst of which
could lead to the remote execution of code.

Background
==========

Apache CouchDB is a distributed, fault-tolerant and schema-free
document-oriented database.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-db/couchdb <= 2.1.2 Vulnerable!
-------------------------------------------------------------------
NOTE: Certain packages are still vulnerable. Users should migrate
to another package if one is available or wait for the
existing packages to be marked stable by their
architecture maintainers.

Description
===========

Multiple vulnerabilities have been discovered in CouchDB. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker could execute arbitrary code or escalate privileges.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

Gentoo has discontinued support for CouchDB and recommends that users
unmerge the package:

# emerge --unmerge "dev-db/couchdb"

References
==========

[ 1 ] CVE-2018-11769
https://nvd.nist.gov/vuln/detail/CVE-2018-11769
[ 2 ] CVE-2018-8007
https://nvd.nist.gov/vuln/detail/CVE-2018-8007

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201812-06

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5




GLSA 201812-07 : SpamAssassin: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201812-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: SpamAssassin: Multiple vulnerabilities
Date: December 15, 2018
Bugs: #666348
ID: 201812-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in SpamAssassin, the worst of
which may lead to remote code execution.

Background
==========

SpamAssassin is an extensible email filter used to identify junk email.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 mail-filter/spamassassin
< 3.4.2-r2 >= 3.4.2-r2

Description
===========

Multiple vulnerabilities have been discovered in SpamAssassin. Please
review the referenced CVE identifiers for details.

Impact
======

A remote attacker could execute arbitrary code, escalate privileges, or
cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All SpamAssassin users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot -v ">=mail-filter/spamassassin-3.4.2-r2"

References
==========

[ 1 ] CVE-2016-1238
https://nvd.nist.gov/vuln/detail/CVE-2016-1238
[ 2 ] CVE-2017-15705
https://nvd.nist.gov/vuln/detail/CVE-2017-15705
[ 3 ] CVE-2018-11780
https://nvd.nist.gov/vuln/detail/CVE-2018-11780
[ 4 ] CVE-2018-11781
https://nvd.nist.gov/vuln/detail/CVE-2018-11781

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201812-07

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5




GLSA 201812-08 : Scala: Privilege escalation
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201812-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Scala: Privilege escalation
Date: December 15, 2018
Bugs: #637940
ID: 201812-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in Scala could result in privilege escalation.

Background
==========

Scala combines object-oriented and functional programming in one
concise, high-level language.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-lang/scala < 2.12.4 >= 2.12.4

Description
===========

It was discovered that Scala's compilation daemon does not properly
manage permissions for private files.

Impact
======

A local attacker could escalate privileges.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Scala users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/scala-2.12.4"

References
==========

[ 1 ] CVE-2017-15288
https://nvd.nist.gov/vuln/detail/CVE-2017-15288

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201812-08

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5







Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/couchdbspamassassinscala_updates_for_gentoo_linux.html)