Chromium Update for Arch Linux
Posted on: 10/19/2018 05:37 AM

Updated chromium packages has been released for Arch Linux

Chromium Update for Arch Linux


Arch Linux Security Advisory ASA-201810-12
==========================================

Severity: Critical
Date : 2018-10-17
CVE-ID : CVE-2018-5179 CVE-2018-17462 CVE-2018-17463 CVE-2018-17464
CVE-2018-17465 CVE-2018-17466 CVE-2018-17467 CVE-2018-17468
CVE-2018-17469 CVE-2018-17470 CVE-2018-17471 CVE-2018-17473
CVE-2018-17474 CVE-2018-17475 CVE-2018-17476 CVE-2018-17477
Package : chromium
Type : multiple issues
Remote : Yes
Link : https://security.archlinux.org/AVG-781

Summary
=======

The package chromium before version 70.0.3538.67-1 is vulnerable to
multiple issues including arbitrary code execution, content spoofing,
sandbox escape, information disclosure and denial of service.

Resolution
==========

Upgrade to 70.0.3538.67-1.

# pacman -Syu "chromium>=70.0.3538.67-1"

The problems have been fixed upstream in version 70.0.3538.67.

Workaround
==========

None.

Description
===========

- CVE-2018-5179 (denial of service)

A security issue has been found in the ServiceWorker component of the
chromium browser before 70.0.3538.67, due to a lack of limits on the
update() function.

- CVE-2018-17462 (sandbox escape)

A sandbox escape has been found in the AppCache component of the
chromium browser before 70.0.3538.67.

- CVE-2018-17463 (arbitrary code execution)

A remote code execution issue has been found in the V8 component of the
chromium browser before 70.0.3538.67.

- CVE-2018-17464 (content spoofing)

A URL spoofing issue has been found in the Omnibox component of the
chromium browser before 70.0.3538.67.

- CVE-2018-17465 (arbitrary code execution)

A use-after-free issue has been found in the V8 component of the
chromium browser before 70.0.3538.67.

- CVE-2018-17466 (arbitrary code execution)

A memory corruption issue has been found in the Angle component of the
chromium browser before 70.0.3538.67.

- CVE-2018-17467 (content spoofing)

A URL spoofing issue has been found in the Omnibox component of the
chromium browser before 70.0.3538.67.

- CVE-2018-17468 (information disclosure)

A cross-origin URL disclosure issue has been found in the Blink
component of the chromium browser before 70.0.3538.67.

- CVE-2018-17469 (arbitrary code execution)

A heap-based buffer overflow has been found in the PDFium component of
the chromium browser before 70.0.3538.67.

- CVE-2018-17470 (arbitrary code execution)

A memory corruption issue has been found in the GPU internals component
of the chromium browser before 70.0.3538.67.

- CVE-2018-17471 (content spoofing)

A security UI occlusion has been found in the the full screen mode of
the chromium browser before 70.0.3538.67.

- CVE-2018-17473 (content spoofing)

A URL spoofing issue has been found in the Omnibox component of the
chromium browser before 70.0.3538.67.

- CVE-2018-17474 (arbitrary code execution)

A use-after-free has been found in the Blink component of the chromium
browser before 70.0.3538.67.

- CVE-2018-17475 (content spoofing)

A URL spoofing issue has been found in the Omnibox component of the
chromium browser before 70.0.3538.67.

- CVE-2018-17476 (content spoofing)

A security UI occlusion has been found in the the full screen mode of
the chromium browser before 70.0.3538.67.

- CVE-2018-17477 (content spoofing)

A UI spoofing issue has been found in the Extensions component of the
chromium browser before 70.0.3538.67.

Impact
======

A remote attacker can spoof the URL or the security status of a page,
access sensitive information, crash the browser or execute arbitrary
code on the affected host.

References
==========

https://chromereleases.googleblog.com/2018/10/stable-channel-update-for-desktop.html
https://bugs.chromium.org/p/chromium/issues/detail?id=805496
https://bugs.chromium.org/p/chromium/issues/detail?id=888926
https://bugs.chromium.org/p/chromium/issues/detail?id=888923
https://bugs.chromium.org/p/chromium/issues/detail?id=887273
https://bugs.chromium.org/p/chromium/issues/detail?id=870226
https://bugs.chromium.org/p/chromium/issues/detail?id=880906
https://bugs.chromium.org/p/chromium/issues/detail?id=844881
https://bugs.chromium.org/p/chromium/issues/detail?id=876822
https://bugs.chromium.org/p/chromium/issues/detail?id=880675
https://bugs.chromium.org/p/chromium/issues/detail?id=877874
https://bugs.chromium.org/p/chromium/issues/detail?id=873080
https://bugs.chromium.org/p/chromium/issues/detail?id=882078
https://bugs.chromium.org/p/chromium/issues/detail?id=843151
https://bugs.chromium.org/p/chromium/issues/detail?id=852634
https://bugs.chromium.org/p/chromium/issues/detail?id=812769
https://bugs.chromium.org/p/chromium/issues/detail?id=863703
https://security.archlinux.org/CVE-2018-5179
https://security.archlinux.org/CVE-2018-17462
https://security.archlinux.org/CVE-2018-17463
https://security.archlinux.org/CVE-2018-17464
https://security.archlinux.org/CVE-2018-17465
https://security.archlinux.org/CVE-2018-17466
https://security.archlinux.org/CVE-2018-17467
https://security.archlinux.org/CVE-2018-17468
https://security.archlinux.org/CVE-2018-17469
https://security.archlinux.org/CVE-2018-17470
https://security.archlinux.org/CVE-2018-17471
https://security.archlinux.org/CVE-2018-17473
https://security.archlinux.org/CVE-2018-17474
https://security.archlinux.org/CVE-2018-17475
https://security.archlinux.org/CVE-2018-17476
https://security.archlinux.org/CVE-2018-17477



Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/chromium_update_for_arch_linux.html)