Bash, Initscripts, Sudo, Nghttp2, Firefox Updates for Oracle Linux
Posted on: 09/11/2019 07:17 AM

The following updates has been released for Oracle Linux:

ELBA-2019-2707 Oracle Linux 8 bash bug fix update
ELBA-2019-2708 Oracle Linux 8 initscripts bug fix update
ELBA-2019-2710 Oracle Linux 8 sudo bug fix update
ELSA-2019-2692 Important: Oracle Linux 8 nghttp2 security update
ELSA-2019-2694 Critical: Oracle Linux 6 firefox security update

ELBA-2019-2707 Oracle Linux 8 bash bug fix update
Oracle Linux Bug Fix Advisory ELBA-2019-2707

http://linux.oracle.com/errata/ELBA-2019-2707.html

The following updated rpms for Oracle Linux 8 have been uploaded to the
Unbreakable Linux Network:

x86_64:
bash-4.4.19-8.el8_0.x86_64.rpm
bash-doc-4.4.19-8.el8_0.x86_64.rpm

aarch64:
bash-4.4.19-8.el8_0.aarch64.rpm
bash-doc-4.4.19-8.el8_0.aarch64.rpm


SRPMS:
http://oss.oracle.com/ol8/SRPMS-updates/bash-4.4.19-8.el8_0.src.rpm



Description of changes:

[4.4.19-8]
- Fix `$$` expansion in subshell
Resolves: #1727952


ELBA-2019-2708 Oracle Linux 8 initscripts bug fix update
Oracle Linux Bug Fix Advisory ELBA-2019-2708

http://linux.oracle.com/errata/ELBA-2019-2708.html

The following updated rpms for Oracle Linux 8 have been uploaded to the
Unbreakable Linux Network:

x86_64:
initscripts-10.00.1-1.el8_0.1.x86_64.rpm
netconsole-service-10.00.1-1.el8_0.1.noarch.rpm
network-scripts-10.00.1-1.el8_0.1.x86_64.rpm
readonly-root-10.00.1-1.el8_0.1.noarch.rpm

aarch64:
initscripts-10.00.1-1.el8_0.1.aarch64.rpm
netconsole-service-10.00.1-1.el8_0.1.noarch.rpm
network-scripts-10.00.1-1.el8_0.1.aarch64.rpm
readonly-root-10.00.1-1.el8_0.1.noarch.rpm


SRPMS:
http://oss.oracle.com/ol8/SRPMS-updates/initscripts-10.00.1-1.el8_0.1.src.rpm



Description of changes:

[10.00.1-1.1]
- rc.d/functions: fix escape sequence being output under systemd service
units


ELBA-2019-2710 Oracle Linux 8 sudo bug fix update
Oracle Linux Bug Fix Advisory ELBA-2019-2710

http://linux.oracle.com/errata/ELBA-2019-2710.html

The following updated rpms for Oracle Linux 8 have been uploaded to the
Unbreakable Linux Network:

x86_64:
sudo-1.8.25p1-4.el8_0.1.x86_64.rpm

aarch64:
sudo-1.8.25p1-4.el8_0.1.aarch64.rpm


SRPMS:
http://oss.oracle.com/ol8/SRPMS-updates/sudo-1.8.25p1-4.el8_0.1.src.rpm



Description of changes:

[1.8.25-4.1]
- RHEL 8.0.0z ERRATUM
- Fixed The LDAP backend which is not properly parsing sudoOptions,
resulting in selinux roles not being applied
Resolves: rhbz#1743168


ELSA-2019-2692 Important: Oracle Linux 8 nghttp2 security update
Oracle Linux Security Advisory ELSA-2019-2692

http://linux.oracle.com/errata/ELSA-2019-2692.html

The following updated rpms for Oracle Linux 8 have been uploaded to the
Unbreakable Linux Network:

x86_64:
libnghttp2-1.33.0-1.el8_0.1.i686.rpm
libnghttp2-1.33.0-1.el8_0.1.x86_64.rpm
libnghttp2-devel-1.33.0-1.el8_0.1.i686.rpm
libnghttp2-devel-1.33.0-1.el8_0.1.x86_64.rpm
nghttp2-1.33.0-1.el8_0.1.x86_64.rpm

aarch64:
libnghttp2-1.33.0-1.el8_0.1.aarch64.rpm
libnghttp2-devel-1.33.0-1.el8_0.1.aarch64.rpm
nghttp2-1.33.0-1.el8_0.1.aarch64.rpm


SRPMS:
http://oss.oracle.com/ol8/SRPMS-updates/nghttp2-1.33.0-1.el8_0.1.src.rpm



Description of changes:

[1.33.0-1.el8_0_0.1]
- backport security fixes from nghttp2-1.39.2 (CVE-2019-9511 and
CVE-2019-9513)


ELSA-2019-2694 Critical: Oracle Linux 6 firefox security update
Oracle Linux Security Advisory ELSA-2019-2694

http://linux.oracle.com/errata/ELSA-2019-2694.html

The following updated rpms for Oracle Linux 6 have been uploaded to the
Unbreakable Linux Network:

i386:
firefox-60.9.0-1.0.1.el6_10.i686.rpm

x86_64:
firefox-60.9.0-1.0.1.el6_10.i686.rpm
firefox-60.9.0-1.0.1.el6_10.x86_64.rpm


SRPMS:
http://oss.oracle.com/ol6/SRPMS-updates/firefox-60.9.0-1.0.1.el6_10.src.rpm



Description of changes:

[60.9.0-1.0.1]
- fix LD_LIBRARY_PATH
- Add firefox-oracle-default-prefs.js and remove the corresponding Red
Hat one

[60.9.0-1]
- Update to 60.9.0 ESR





Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/bashinitscriptssudonghttp2firefox_updates_for_oracle_linux.html)