Aubio, Kconfig, Chromium Updates for openSUSE
Posted on: 08/13/2019 03:04 PM

The following updates has been released for openSUSE:

openSUSE-SU-2019:1851-1: important: Security update for kconfig, kdelibs4
openSUSE-SU-2019:1852-1: moderate: Security update for aubio
openSUSE-SU-2019:1853-1: important: Security update for chromium

openSUSE-SU-2019:1851-1: important: Security update for kconfig, kdelibs4
openSUSE Security Update: Security update for kconfig, kdelibs4
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1851-1
Rating: important
References: #1144600
Cross-References: CVE-2019-14744
Affected Products:
openSUSE Leap 15.1
openSUSE Leap 15.0
openSUSE Backports SLE-15
SUSE Package Hub for SUSE Linux Enterprise 12
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for kconfig, kdelibs4 fixes the following issues:

- CVE-2019-14744: Fixed a command execution by an shell expansion
(boo#1144600).


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-1851=1

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1851=1

- openSUSE Backports SLE-15:

zypper in -t patch openSUSE-2019-1851=1

- SUSE Package Hub for SUSE Linux Enterprise 12:

zypper in -t patch openSUSE-2019-1851=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

kconf_update5-5.55.0-lp151.2.5.1
kconf_update5-debuginfo-5.55.0-lp151.2.5.1
kconfig-debugsource-5.55.0-lp151.2.5.1
kconfig-devel-5.55.0-lp151.2.5.1
kconfig-devel-debuginfo-5.55.0-lp151.2.5.1
kdelibs4-4.14.38-lp151.9.5.1
kdelibs4-branding-upstream-4.14.38-lp151.9.5.1
kdelibs4-core-4.14.38-lp151.9.5.1
kdelibs4-core-debuginfo-4.14.38-lp151.9.5.1
kdelibs4-debuginfo-4.14.38-lp151.9.5.1
kdelibs4-debugsource-4.14.38-lp151.9.5.1
kdelibs4-doc-4.14.38-lp151.9.5.1
kdelibs4-doc-debuginfo-4.14.38-lp151.9.5.1
libKF5ConfigCore5-5.55.0-lp151.2.5.1
libKF5ConfigCore5-debuginfo-5.55.0-lp151.2.5.1
libKF5ConfigGui5-5.55.0-lp151.2.5.1
libKF5ConfigGui5-debuginfo-5.55.0-lp151.2.5.1
libkde4-4.14.38-lp151.9.5.1
libkde4-debuginfo-4.14.38-lp151.9.5.1
libkde4-devel-4.14.38-lp151.9.5.1
libkde4-devel-debuginfo-4.14.38-lp151.9.5.1
libkdecore4-4.14.38-lp151.9.5.1
libkdecore4-debuginfo-4.14.38-lp151.9.5.1
libkdecore4-devel-4.14.38-lp151.9.5.1
libkdecore4-devel-debuginfo-4.14.38-lp151.9.5.1
libksuseinstall-devel-4.14.38-lp151.9.5.1
libksuseinstall1-4.14.38-lp151.9.5.1
libksuseinstall1-debuginfo-4.14.38-lp151.9.5.1

- openSUSE Leap 15.1 (noarch):

kdelibs4-apidocs-4.14.38-lp151.9.5.1
libKF5ConfigCore5-lang-5.55.0-lp151.2.5.1

- openSUSE Leap 15.1 (x86_64):

kconfig-devel-32bit-5.55.0-lp151.2.5.1
kconfig-devel-32bit-debuginfo-5.55.0-lp151.2.5.1
libKF5ConfigCore5-32bit-5.55.0-lp151.2.5.1
libKF5ConfigCore5-32bit-debuginfo-5.55.0-lp151.2.5.1
libKF5ConfigGui5-32bit-5.55.0-lp151.2.5.1
libKF5ConfigGui5-32bit-debuginfo-5.55.0-lp151.2.5.1
libkde4-32bit-4.14.38-lp151.9.5.1
libkde4-32bit-debuginfo-4.14.38-lp151.9.5.1
libkdecore4-32bit-4.14.38-lp151.9.5.1
libkdecore4-32bit-debuginfo-4.14.38-lp151.9.5.1
libksuseinstall1-32bit-4.14.38-lp151.9.5.1
libksuseinstall1-32bit-debuginfo-4.14.38-lp151.9.5.1

- openSUSE Leap 15.0 (i586 x86_64):

kconf_update5-5.45.0-lp150.2.5.1
kconf_update5-debuginfo-5.45.0-lp150.2.5.1
kconfig-debugsource-5.45.0-lp150.2.5.1
kconfig-devel-5.45.0-lp150.2.5.1
kconfig-devel-debuginfo-5.45.0-lp150.2.5.1
kdelibs4-4.14.38-lp150.6.5.1
kdelibs4-branding-upstream-4.14.38-lp150.6.5.1
kdelibs4-core-4.14.38-lp150.6.5.1
kdelibs4-core-debuginfo-4.14.38-lp150.6.5.1
kdelibs4-debuginfo-4.14.38-lp150.6.5.1
kdelibs4-debugsource-4.14.38-lp150.6.5.1
kdelibs4-doc-4.14.38-lp150.6.5.1
kdelibs4-doc-debuginfo-4.14.38-lp150.6.5.1
libKF5ConfigCore5-5.45.0-lp150.2.5.1
libKF5ConfigCore5-debuginfo-5.45.0-lp150.2.5.1
libKF5ConfigGui5-5.45.0-lp150.2.5.1
libKF5ConfigGui5-debuginfo-5.45.0-lp150.2.5.1
libkde4-4.14.38-lp150.6.5.1
libkde4-debuginfo-4.14.38-lp150.6.5.1
libkde4-devel-4.14.38-lp150.6.5.1
libkde4-devel-debuginfo-4.14.38-lp150.6.5.1
libkdecore4-4.14.38-lp150.6.5.1
libkdecore4-debuginfo-4.14.38-lp150.6.5.1
libkdecore4-devel-4.14.38-lp150.6.5.1
libkdecore4-devel-debuginfo-4.14.38-lp150.6.5.1
libksuseinstall-devel-4.14.38-lp150.6.5.1
libksuseinstall1-4.14.38-lp150.6.5.1
libksuseinstall1-debuginfo-4.14.38-lp150.6.5.1

- openSUSE Leap 15.0 (noarch):

kdelibs4-apidocs-4.14.38-lp150.6.5.1
libKF5ConfigCore5-lang-5.45.0-lp150.2.5.1

- openSUSE Leap 15.0 (x86_64):

kconfig-devel-32bit-5.45.0-lp150.2.5.1
kconfig-devel-32bit-debuginfo-5.45.0-lp150.2.5.1
libKF5ConfigCore5-32bit-5.45.0-lp150.2.5.1
libKF5ConfigCore5-32bit-debuginfo-5.45.0-lp150.2.5.1
libKF5ConfigGui5-32bit-5.45.0-lp150.2.5.1
libKF5ConfigGui5-32bit-debuginfo-5.45.0-lp150.2.5.1
libkde4-32bit-4.14.38-lp150.6.5.1
libkde4-32bit-debuginfo-4.14.38-lp150.6.5.1
libkdecore4-32bit-4.14.38-lp150.6.5.1
libkdecore4-32bit-debuginfo-4.14.38-lp150.6.5.1
libksuseinstall1-32bit-4.14.38-lp150.6.5.1
libksuseinstall1-32bit-debuginfo-4.14.38-lp150.6.5.1

- openSUSE Backports SLE-15 (aarch64 ppc64le s390x x86_64):

kconf_update5-5.45.0-bp150.3.5.1
kconf_update5-debuginfo-5.45.0-bp150.3.5.1
kconfig-debugsource-5.45.0-bp150.3.5.1
kconfig-devel-5.45.0-bp150.3.5.1
kconfig-devel-debuginfo-5.45.0-bp150.3.5.1
kdelibs4-4.14.38-bp150.3.5.1
kdelibs4-branding-upstream-4.14.38-bp150.3.5.1
kdelibs4-core-4.14.38-bp150.3.5.1
kdelibs4-core-debuginfo-4.14.38-bp150.3.5.1
kdelibs4-debuginfo-4.14.38-bp150.3.5.1
kdelibs4-debugsource-4.14.38-bp150.3.5.1
kdelibs4-doc-4.14.38-bp150.3.5.1
kdelibs4-doc-debuginfo-4.14.38-bp150.3.5.1
libKF5ConfigCore5-5.45.0-bp150.3.5.1
libKF5ConfigCore5-debuginfo-5.45.0-bp150.3.5.1
libKF5ConfigGui5-5.45.0-bp150.3.5.1
libKF5ConfigGui5-debuginfo-5.45.0-bp150.3.5.1
libkde4-4.14.38-bp150.3.5.1
libkde4-debuginfo-4.14.38-bp150.3.5.1
libkde4-devel-4.14.38-bp150.3.5.1
libkde4-devel-debuginfo-4.14.38-bp150.3.5.1
libkdecore4-4.14.38-bp150.3.5.1
libkdecore4-debuginfo-4.14.38-bp150.3.5.1
libkdecore4-devel-4.14.38-bp150.3.5.1
libkdecore4-devel-debuginfo-4.14.38-bp150.3.5.1
libksuseinstall-devel-4.14.38-bp150.3.5.1
libksuseinstall1-4.14.38-bp150.3.5.1
libksuseinstall1-debuginfo-4.14.38-bp150.3.5.1

- openSUSE Backports SLE-15 (aarch64_ilp32):

kconfig-devel-64bit-5.45.0-bp150.3.5.1
kconfig-devel-64bit-debuginfo-5.45.0-bp150.3.5.1
libKF5ConfigCore5-64bit-5.45.0-bp150.3.5.1
libKF5ConfigCore5-64bit-debuginfo-5.45.0-bp150.3.5.1
libKF5ConfigGui5-64bit-5.45.0-bp150.3.5.1
libKF5ConfigGui5-64bit-debuginfo-5.45.0-bp150.3.5.1
libkde4-64bit-4.14.38-bp150.3.5.1
libkde4-64bit-debuginfo-4.14.38-bp150.3.5.1
libkdecore4-64bit-4.14.38-bp150.3.5.1
libkdecore4-64bit-debuginfo-4.14.38-bp150.3.5.1
libksuseinstall1-64bit-4.14.38-bp150.3.5.1
libksuseinstall1-64bit-debuginfo-4.14.38-bp150.3.5.1

- openSUSE Backports SLE-15 (noarch):

kdelibs4-apidocs-4.14.38-bp150.3.5.1
libKF5ConfigCore5-lang-5.45.0-bp150.3.5.1

- SUSE Package Hub for SUSE Linux Enterprise 12 (aarch64 ppc64le s390x x86_64):

kconf_update5-5.20.0-8.1
kconf_update5-5.26.0-8.1
kconf_update5-5.32.0-7.1
kconf_update5-debuginfo-5.20.0-8.1
kconf_update5-debuginfo-5.26.0-8.1
kconf_update5-debuginfo-5.32.0-7.1
kconfig-debugsource-5.20.0-8.1
kconfig-debugsource-5.26.0-8.1
kconfig-debugsource-5.32.0-7.1
kconfig-devel-5.20.0-8.1
kconfig-devel-5.26.0-8.1
kconfig-devel-5.32.0-7.1
kconfig-devel-debuginfo-5.20.0-8.1
kconfig-devel-debuginfo-5.26.0-8.1
kconfig-devel-debuginfo-5.32.0-7.1
kdelibs4-4.14.18-14.1
kdelibs4-4.14.25-13.1
kdelibs4-4.14.33-7.2
kdelibs4-branding-upstream-4.14.18-14.1
kdelibs4-branding-upstream-4.14.25-13.1
kdelibs4-branding-upstream-4.14.33-7.2
kdelibs4-core-4.14.18-14.1
kdelibs4-core-4.14.25-13.1
kdelibs4-core-4.14.33-7.2
kdelibs4-core-debuginfo-4.14.18-14.1
kdelibs4-core-debuginfo-4.14.25-13.1
kdelibs4-core-debuginfo-4.14.33-7.2
kdelibs4-debuginfo-4.14.18-14.1
kdelibs4-debuginfo-4.14.25-13.1
kdelibs4-debuginfo-4.14.33-7.2
kdelibs4-debugsource-4.14.18-14.1
kdelibs4-debugsource-4.14.25-13.1
kdelibs4-debugsource-4.14.33-7.2
kdelibs4-doc-4.14.18-14.1
kdelibs4-doc-4.14.25-13.1
kdelibs4-doc-4.14.33-7.2
kdelibs4-doc-debuginfo-4.14.18-14.1
kdelibs4-doc-debuginfo-4.14.25-13.1
kdelibs4-doc-debuginfo-4.14.33-7.2
libKF5ConfigCore5-5.20.0-8.1
libKF5ConfigCore5-5.26.0-8.1
libKF5ConfigCore5-5.32.0-7.1
libKF5ConfigCore5-debuginfo-5.20.0-8.1
libKF5ConfigCore5-debuginfo-5.26.0-8.1
libKF5ConfigCore5-debuginfo-5.32.0-7.1
libKF5ConfigGui5-5.20.0-8.1
libKF5ConfigGui5-5.26.0-8.1
libKF5ConfigGui5-5.32.0-7.1
libKF5ConfigGui5-debuginfo-5.20.0-8.1
libKF5ConfigGui5-debuginfo-5.26.0-8.1
libKF5ConfigGui5-debuginfo-5.32.0-7.1
libkde4-4.14.18-14.1
libkde4-4.14.25-13.1
libkde4-4.14.33-7.2
libkde4-debuginfo-4.14.18-14.1
libkde4-debuginfo-4.14.25-13.1
libkde4-debuginfo-4.14.33-7.2
libkde4-devel-4.14.18-14.1
libkde4-devel-4.14.25-13.1
libkde4-devel-4.14.33-7.2
libkdecore4-4.14.18-14.1
libkdecore4-4.14.25-13.1
libkdecore4-4.14.33-7.2
libkdecore4-debuginfo-4.14.18-14.1
libkdecore4-debuginfo-4.14.25-13.1
libkdecore4-debuginfo-4.14.33-7.2
libkdecore4-devel-4.14.18-14.1
libkdecore4-devel-4.14.25-13.1
libkdecore4-devel-4.14.33-7.2
libkdecore4-devel-debuginfo-4.14.18-14.1
libkdecore4-devel-debuginfo-4.14.25-13.1
libkdecore4-devel-debuginfo-4.14.33-7.2
libksuseinstall-devel-4.14.18-14.1
libksuseinstall-devel-4.14.25-13.1
libksuseinstall-devel-4.14.33-7.2
libksuseinstall1-4.14.18-14.1
libksuseinstall1-4.14.25-13.1
libksuseinstall1-4.14.33-7.2
libksuseinstall1-debuginfo-4.14.18-14.1
libksuseinstall1-debuginfo-4.14.25-13.1
libksuseinstall1-debuginfo-4.14.33-7.2

- SUSE Package Hub for SUSE Linux Enterprise 12 (aarch64_ilp32):

kconfig-devel-64bit-5.32.0-7.1
kconfig-devel-debuginfo-64bit-5.32.0-7.1
libKF5ConfigCore5-64bit-5.32.0-7.1
libKF5ConfigCore5-debuginfo-64bit-5.32.0-7.1
libKF5ConfigGui5-64bit-5.32.0-7.1
libKF5ConfigGui5-debuginfo-64bit-5.32.0-7.1
libkde4-64bit-4.14.33-7.2
libkde4-debuginfo-64bit-4.14.33-7.2
libkdecore4-64bit-4.14.33-7.2
libkdecore4-debuginfo-64bit-4.14.33-7.2
libksuseinstall1-64bit-4.14.33-7.2
libksuseinstall1-debuginfo-64bit-4.14.33-7.2

- SUSE Package Hub for SUSE Linux Enterprise 12 (noarch):

kdelibs4-apidocs-4.14.18-14.1
kdelibs4-apidocs-4.14.25-13.1
kdelibs4-apidocs-4.14.33-7.2
libKF5ConfigCore5-lang-5.20.0-8.1
libKF5ConfigCore5-lang-5.26.0-8.1
libKF5ConfigCore5-lang-5.32.0-7.1


References:

https://www.suse.com/security/cve/CVE-2019-14744.html
https://bugzilla.suse.com/1144600

--



openSUSE-SU-2019:1852-1: moderate: Security update for aubio
openSUSE Security Update: Security update for aubio
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1852-1
Rating: moderate
References: #1137823 #1142433 #1142435 #1142436
Cross-References: CVE-2018-19802 CVE-2019-1010222 CVE-2019-1010223
CVE-2019-1010224
Affected Products:
openSUSE Backports SLE-15
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

This update for aubio fixes the following issues:

- CVE-2019-1010224: Fixed a denial of service (boo#1142435).

This update was imported from the openSUSE:Leap:15.0:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Backports SLE-15:

zypper in -t patch openSUSE-2019-1852=1



Package List:

- openSUSE Backports SLE-15 (aarch64 ppc64le s390x x86_64):

python-aubio-debugsource-0.4.6-bp150.3.15.1
python2-aubio-0.4.6-bp150.3.15.1
python2-aubio-debuginfo-0.4.6-bp150.3.15.1
python3-aubio-0.4.6-bp150.3.15.1
python3-aubio-debuginfo-0.4.6-bp150.3.15.1

- openSUSE Backports SLE-15 (x86_64):

aubio-tools-0.4.6-bp150.3.15.1
libaubio-devel-0.4.6-bp150.3.15.1
libaubio5-0.4.6-bp150.3.15.1


References:

https://www.suse.com/security/cve/CVE-2018-19802.html
https://www.suse.com/security/cve/CVE-2019-1010222.html
https://www.suse.com/security/cve/CVE-2019-1010223.html
https://www.suse.com/security/cve/CVE-2019-1010224.html
https://bugzilla.suse.com/1137823
https://bugzilla.suse.com/1142433
https://bugzilla.suse.com/1142435
https://bugzilla.suse.com/1142436

--



openSUSE-SU-2019:1853-1: important: Security update for chromium
openSUSE Security Update: Security update for chromium
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1853-1
Rating: important
References: #1143492 #1144625
Cross-References: CVE-2019-5850 CVE-2019-5851 CVE-2019-5852
CVE-2019-5853 CVE-2019-5854 CVE-2019-5855
CVE-2019-5856 CVE-2019-5857 CVE-2019-5858
CVE-2019-5859 CVE-2019-5860 CVE-2019-5861
CVE-2019-5862 CVE-2019-5863 CVE-2019-5864
CVE-2019-5865
Affected Products:
openSUSE Backports SLE-15
______________________________________________________________________________

An update that fixes 16 vulnerabilities is now available.

Description:

This update for chromium to version 76.0.3809.87 fixes the following
issues:

- CVE-2019-5850: Use-after-free in offline page fetcher (boo#1143492)
- CVE-2019-5860: Use-after-free in PDFium (boo#1143492)
- CVE-2019-5853: Memory corruption in regexp length check (boo#1143492)
- CVE-2019-5851: Use-after-poison in offline audio context (boo#1143492)
- CVE-2019-5859: res: URIs can load alternative browsers (boo#1143492)
- CVE-2019-5856: Insufficient checks on filesystem: URI permissions
(boo#1143492)
- CVE-2019-5855: Integer overflow in PDFium (boo#1143492)
- CVE-2019-5865: Site isolation bypass from compromised renderer
(boo#1143492)
- CVE-2019-5858: Insufficient filtering of Open URL service parameters
(boo#1143492)
- CVE-2019-5864: Insufficient port filtering in CORS for extensions
(boo#1143492)
- CVE-2019-5862: AppCache not robust to compromised renderers (boo#1143492)
- CVE-2019-5861: Click location incorrectly checked (boo#1143492)
- CVE-2019-5857: Comparison of -0 and null yields crash (boo#1143492)
- CVE-2019-5854: Integer overflow in PDFium text rendering (boo#1143492)
- CVE-2019-5852: Object leak of utility functions (boo#1143492)

This update was imported from the openSUSE:Leap:15.0:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Backports SLE-15:

zypper in -t patch openSUSE-2019-1853=1



Package List:

- openSUSE Backports SLE-15 (aarch64 x86_64):

chromedriver-76.0.3809.87-bp150.220.1
chromium-76.0.3809.87-bp150.220.1


References:

https://www.suse.com/security/cve/CVE-2019-5850.html
https://www.suse.com/security/cve/CVE-2019-5851.html
https://www.suse.com/security/cve/CVE-2019-5852.html
https://www.suse.com/security/cve/CVE-2019-5853.html
https://www.suse.com/security/cve/CVE-2019-5854.html
https://www.suse.com/security/cve/CVE-2019-5855.html
https://www.suse.com/security/cve/CVE-2019-5856.html
https://www.suse.com/security/cve/CVE-2019-5857.html
https://www.suse.com/security/cve/CVE-2019-5858.html
https://www.suse.com/security/cve/CVE-2019-5859.html
https://www.suse.com/security/cve/CVE-2019-5860.html
https://www.suse.com/security/cve/CVE-2019-5861.html
https://www.suse.com/security/cve/CVE-2019-5862.html
https://www.suse.com/security/cve/CVE-2019-5863.html
https://www.suse.com/security/cve/CVE-2019-5864.html
https://www.suse.com/security/cve/CVE-2019-5865.html
https://bugzilla.suse.com/1143492
https://bugzilla.suse.com/1144625

--






Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/aubiokconfigchromium_updates_for_opensuse.html)