Advancecomp/GraphicsMagick Updates for Debian 7 LTS
Posted on: 02/14/2018 08:52 AM

The following updates has been released for Debian GNU/Linux 7 LTS:

DLA 1281-1: advancecomp security update
DLA 1282-1: graphicsmagick security update

DLA 1281-1: advancecomp security update



Package : advancecomp
Version : 1.15-1+deb7u1
CVE ID : CVE-2018-1056
Debian Bug : 889270

Joonun Jang discovered that the advzip tool in advancecomp, a
collection of recompression utilities, was prone to a heap-based
buffer overflow. This might allow an attacker to cause a
denial-of-service (application crash) or other unspecified impact via
a crafted file.

For Debian 7 "Wheezy", these problems have been fixed in version
1.15-1+deb7u1.

We recommend that you upgrade your advancecomp packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS



DLA 1282-1: graphicsmagick security update
Package : graphicsmagick
Version : 1.3.16-1.1+deb7u18
CVE ID : CVE-2018-6799


A denial of service vulnerability has been discovered in graphicsmagick,
a collection of image processing tools and associated libraries.

A specially crafted file can be used to produce a denial of service
(heap overwrite) or possible other unspecified impact by exploiting a
defect related to unused pixel staging area in the AcquireCacheNexus
function in magick/pixel_cache.c.

For Debian 7 "Wheezy", these problems have been fixed in version
1.3.16-1.1+deb7u18.

We recommend that you upgrade your graphicsmagick packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS







Printed from Linux Compatible (https://www.linuxcompatible.org/news/story/advancecompgraphicsmagick_updates_for_debian_7_lts.html)