zlib DoS (SSA:2005-189-01)
Posted on: 07/09/2005 08:57 AM

New zlib packages are available for Slackware 10.0, 10.1, and -current to fix a denial of service security issue. zlib 1.1.x is not affected.

More details about this issue may be found in the Common Vulnerabilities and Exposures (CVE) database:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2096

Here are the details from the Slackware 10.1 ChangeLog:
+--------------------------+
patches/packages/zlib-1.2.2-i486-2.tgz: Patched an overflow in zlib that
could cause applications using zlib to crash. The overflow does not
involve user supplied data, and therefore does not allow the execution of
arbitrary code. However, it could still be used by a remote attacker to
create a denial of service.
For more information, see:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2096
(* Security fix *)
+--------------------------+


Where to find the new packages:
+-----------------------------+

Updated package for Slackware 10.0:
ftp://ftp.slackware.com/pub/slackware/slackware-10.0/patches/packages/zlib-1.2.2-i486-2.tgz

Updated package for Slackware 10.1:
ftp://ftp.slackware.com/pub/slackware/slackware-10.1/patches/packages/zlib-1.2.2-i486-2.tgz

Updated package for Slackware -current:
ftp://ftp.slackware.com/pub/slackware/slackware-current/slackware/l/zlib-1.2.2-i486-2.tgz


MD5 signatures:
+-------------+

Slackware 10.0 package:
246822a5bcccc0cee161c3d04a40976d zlib-1.2.2-i486-2.tgz

Slackware 10.1 package:
67a4e6c58452e578966cbceac68d7468 zlib-1.2.2-i486-2.tgz

Slackware -current package:
c0a12d869c01823531c8c52aee542f5c zlib-1.2.2-i486-2.tgz


Installation instructions:
+------------------------+

Upgrade the package as root:
# upgradepkg zlib-1.2.2-i486-2.tgz


+-----+

Slackware Linux Security Team
http://slackware.com/gpg-key
security@slackware.com


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/zlib_dos_ssa2005_189_01.html)