yum 2.4 for CentOS-3 i386/x86_64 (CENTOSPLUS only)
Posted on: 11/07/2007 10:20 PM

yum-2.4 and required dependancies for CentOS-3 are now available for i386 and x86_64 in the centosplus repository.

The default version still is 2.0, nothing changes for those who don't want/need the new features (for example: fastestmirror, priorities and protectbase).

For those who don't want to update to yum-2.4 but still use the centosplus repository, add to your /etc/yum.conf the line:
exclude= yum

The old metadata for yum-2.0 (yum-arch) and the new metadata for yum-2.4 (createrepo) are BOTH generated on all the CentOS-3 repositories on the centos.org mirrors.

Caveat: the 3rd parties repositories using only yum-2.0 metadata will NOT be compatible with the yum-2.4 until their respective maintainers also create the new metadata.

yum update procedure:
1) enable the centosplus repository in /etc/yum.conf
#additional packages that extend functionality of existing packages
[centosplus]
name=CentOS-$releasever - Plus
baseurl=http://mirror.centos.org/centos/$releasever/centosplus/$basearch/
gpgcheck=1

2) update
# yum update

3) fix the yum.conf file:
# mv /etc/yum.conf /etc/yum.conf-2.0.x
# mv /etc/yum.conf.rpmnew /etc/yum.conf

4) optionally re-add the custom repositories to /etc/yum.repos.d

Cheers,

The CentOS team




Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/yum_24_for_centos_3_i386x86_64_centosplus_only.html)