XV (SSA:2005-195-02)
Posted on: 07/15/2005 05:16 AM

New XV image viewer packages are available for Slackware 8.1, 9.0, 9.1, 10.0, 10.1, and -current to fix security issues. Format string and other issues could cause a crash or execution of arbitrary code if a specially crafted image is loaded with XV.

Here are the details from the Slackware 10.1 ChangeLog:
+--------------------------+
patches/packages/xv-3.10a-i486-4.tgz: Upgraded to the latest XV jumbo
patches, xv-3.10a-jumbo-fix-patch-20050410 and
xv-3.10a-jumbo-enh-patch-20050501. These fix a number of format string
and other possible security issues in addition to providing many other
bugfixes and enhancements.
(Thanks to Greg Roelofs)
(* Security fix *)
+--------------------------+


Where to find the new packages:
+-----------------------------+

Updated package for Slackware 8.1:
ftp://ftp.slackware.com/pub/slackware/slackware-8.1/patches/packages/xv-3.10a-i386-4.tgz

Updated package for Slackware 9.0:
ftp://ftp.slackware.com/pub/slackware/slackware-9.0/patches/packages/xv-3.10a-i386-4.tgz

Updated package for Slackware 9.1:
ftp://ftp.slackware.com/pub/slackware/slackware-9.1/patches/packages/xv-3.10a-i486-4.tgz

Updated package for Slackware 10.0:
ftp://ftp.slackware.com/pub/slackware/slackware-10.0/patches/packages/xv-3.10a-i486-4.tgz

Updated package for Slackware 10.1:
ftp://ftp.slackware.com/pub/slackware/slackware-10.1/patches/packages/xv-3.10a-i486-4.tgz

Updated package for Slackware -current:
ftp://ftp.slackware.com/pub/slackware/slackware-current/slackware/xap/xv-3.10a-i486-4.tgz


MD5 signatures:
+-------------+

Slackware 8.1 package:
93a5c439abfd38c5756ec722241933dc xv-3.10a-i386-4.tgz

Slackware 9.0 package:
ab790daee1531ed6ee311831717e2933 xv-3.10a-i386-4.tgz

Slackware 9.1 package:
aaf1269856d9239209d8c4b0ae28869f xv-3.10a-i486-4.tgz

Slackware 10.0 package:
8b9c9898f5a90ffde882ae588b1ea8bc xv-3.10a-i486-4.tgz

Slackware 10.1 package:
21173a21c6423f952d944c0b3712a4d6 xv-3.10a-i486-4.tgz

Slackware -current package:
4ce3ef84a524093467466f0df30c2672 xv-3.10a-i486-4.tgz


Installation instructions:
+------------------------+

Upgrade the package as root:
# upgradepkg xv-3.10a-i486-4.tgz


+-----+

Slackware Linux Security Team
http://slackware.com/gpg-key
security@slackware.com


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/xv_ssa2005_195_02.html)