Xmltooling/Newsbeuter Updates for openSUSE
Posted on: 01/21/2018 02:07 PM

The following updates has been released for openSUSE:

openSUSE-SU-2018:0158-1: important: Security update for xmltooling
openSUSE-SU-2018:0166-1: important: Security update for newsbeuter

openSUSE-SU-2018:0158-1: important: Security update for xmltooling
openSUSE Security Update: Security update for xmltooling
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0158-1
Rating: important
References: #1075975
Cross-References: CVE-2018-0486
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for xmltooling fixes the following issues:

- CVE-2018-0486: Fixed a security bug when xmltooling mishandles digital
signatures of user attribute data, which allows remote attackers to
obtain sensitive information or conduct impersonation attacks via a
crafted DTD (bsc#1075975)

This update was imported from the SUSE:SLE-12-SP1:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-65=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2018-65=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (x86_64):

libxmltooling-devel-1.5.6-6.1
libxmltooling6-1.5.6-6.1
libxmltooling6-debuginfo-1.5.6-6.1
xmltooling-debugsource-1.5.6-6.1
xmltooling-schemas-1.5.6-6.1

- openSUSE Leap 42.2 (x86_64):

libxmltooling-devel-1.5.6-3.3.1
libxmltooling6-1.5.6-3.3.1
libxmltooling6-debuginfo-1.5.6-3.3.1
xmltooling-debugsource-1.5.6-3.3.1
xmltooling-schemas-1.5.6-3.3.1


References:

https://www.suse.com/security/cve/CVE-2018-0486.html
https://bugzilla.suse.com/1075975



openSUSE-SU-2018:0166-1: important: Security update for newsbeuter
openSUSE Security Update: Security update for newsbeuter
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0166-1
Rating: important
References: #1054578
Cross-References: CVE-2017-12904
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for newsbeuter fixes one issues.

This security issue was fixed:

- CVE-2017-12904: Improper neutralization of special elements allowed
remote attackers to perform user-assisted code execution by crafting an
RSS item that includes shell code in its title and/or URL (bsc#1054578).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-62=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2018-62=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (x86_64):

newsbeuter-2.9-5.1
newsbeuter-debuginfo-2.9-5.1
newsbeuter-debugsource-2.9-5.1

- openSUSE Leap 42.3 (noarch):

newsbeuter-lang-2.9-5.1

- openSUSE Leap 42.2 (noarch):

newsbeuter-lang-2.9-2.3.1

- openSUSE Leap 42.2 (x86_64):

newsbeuter-2.9-2.3.1
newsbeuter-debuginfo-2.9-2.3.1
newsbeuter-debugsource-2.9-2.3.1


References:

https://www.suse.com/security/cve/CVE-2017-12904.html
https://bugzilla.suse.com/1054578





Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/xmltoolingnewsbeuter_updates_for_opensuse.html)