xine-lib (SSA:2008-089-03)
Posted on: 03/30/2008 01:55 PM

New xine-lib packages are available for Slackware 10.0, 10.1, 10.2, 11.0, 12.0, and -current to fix security issues.

More details about this issue may be found in the Common Vulnerabilities and Exposures (CVE) database:

Here are the details from the Slackware 12.0 ChangeLog:
Earlier versions of xine-lib suffer from an array index bug that
may have security implications if a malicious RTSP stream is
played. Playback of other media formats is not affected.
If you use RTSP, you should probably upgrade xine-lib.
For more information on the security issue, please see:
(* Security fix *)

Where to find the new packages:

Updated package for Slackware 10.0:

Updated package for Slackware 10.1:

Updated package for Slackware 10.2:

Updated package for Slackware 11.0:

Updated package for Slackware 12.0:

Updated package for Slackware -current:

MD5 signatures:

Slackware 10.0 package:
6b92de022505be8325e7e4abcc0f01de xine-lib-1.1.11-i686-1_slack10.0.tgz

Slackware 10.1 package:
df802bf3a66c1212953600a24f1dba49 xine-lib-1.1.11-i686-1_slack10.1.tgz

Slackware 10.2 package:
6e4306bbc8ed6280f33883097296fb76 xine-lib-1.1.11-i686-1_slack10.2.tgz

Slackware 11.0 package:
012c8ad12a1456e31f9bf299b878b19b xine-lib-1.1.11-i686-1_slack11.0.tgz

Slackware 12.0 package:
04dfd67cfc12258f05b2e01612494572 xine-lib-1.1.11-i686-1_slack12.0.tgz

Slackware -current package:
db569bcc52fffaa132b16d967ddfe495 xine-lib-1.1.11-i686-1.tgz

Installation instructions:

Upgrade the package as root:
# upgradepkg xine-lib-1.1.11-i686-1_slack12.0.tgz


Slackware Linux Security Team

Printed from Linux Compatible (