Xen Security Update for openSUSE 11.3/11.4
Posted on: 08/25/2011 10:37 AM

A security update for Xen is available for openSUSE 11.3 and 11.4

openSUSE Security Update: xen: Fixed a security bug and various other bugs
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:0941-1
Rating: important
References: #582265 #670465 #684297 #684305 #689954 #692625
#693472 #702025 #703924
Cross-References: CVE-2011-1898
Affected Products:
openSUSE 11.4
openSUSE 11.3
______________________________________________________________________________

An update that solves one vulnerability and has 8 fixes is
now available. It includes one version update.

Description:

Security / Collective Update for Xen

Xen:

- bnc#702025 - VUL-0: xen: VT-d (PCI passthrough) MSI trap
injection (CVE-2011-1898)
- bnc#703924 - update block-npiv scripts to support BFA HBA
- bnc#689954 - L3: Live migrations fail when guest crashes:
domain_crash_sync called from entry.S
- bnc#693472 - Bridge hangs cause redundant ring failures
in SLE 11 SP1 HAE + XEN
- bnc#582265 - xen-scsi.ko not supported
- bnc#670465 - When connecting to Xen guest through
vncviewer mouse tracking is off.
- bnc#684305 - on_crash is being ignored with kdump now
working in HVM

vm-install:

- bnc#692625 - virt-manager has problems to install guest
from multiple CD


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch xen-201107-4929

- openSUSE 11.3:

zypper in -t patch xen-201107-4930

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64) [New Version: 0.4.31]:

vm-install-0.4.31-0.4.1
xen-4.0.2_52-0.2.1
xen-devel-4.0.2_52-0.2.1
xen-doc-html-4.0.2_52-0.2.1
xen-doc-pdf-4.0.2_52-0.2.1
xen-kmp-default-4.0.2_52_k2.6.37.6_0.7-0.2.1
xen-kmp-desktop-4.0.2_52_k2.6.37.6_0.7-0.2.1
xen-libs-4.0.2_52-0.2.1
xen-tools-4.0.2_52-0.2.1
xen-tools-domU-4.0.2_52-0.2.1

- openSUSE 11.4 (i586):

xen-kmp-pae-4.0.2_52_k2.6.37.6_0.7-0.2.1

- openSUSE 11.3 (i586 x86_64) [New Version: 0.4.31]:

vm-install-0.4.31-0.4.1
xen-4.0.2_21511_02-0.5.2
xen-devel-4.0.2_21511_02-0.5.2
xen-doc-html-4.0.2_21511_02-0.5.2
xen-doc-pdf-4.0.2_21511_02-0.5.2
xen-kmp-default-4.0.2_21511_02_k2.6.34.10_0.2-0.5.2
xen-kmp-desktop-4.0.2_21511_02_k2.6.34.10_0.2-0.5.2
xen-libs-4.0.2_21511_02-0.5.2
xen-tools-4.0.2_21511_02-0.5.2
xen-tools-domU-4.0.2_21511_02-0.5.2

- openSUSE 11.3 (i586):

xen-kmp-pae-4.0.2_21511_02_k2.6.34.10_0.2-0.5.2


References:

http://support.novell.com/security/cve/CVE-2011-1898.html
https://bugzilla.novell.com/582265
https://bugzilla.novell.com/670465
https://bugzilla.novell.com/684297
https://bugzilla.novell.com/684305
https://bugzilla.novell.com/689954
https://bugzilla.novell.com/692625
https://bugzilla.novell.com/693472
https://bugzilla.novell.com/702025
https://bugzilla.novell.com/703924



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/xen_security_update_for_opensuse_11_311_4.html)