Wireshark/Net-SNMP Updates for Gentoo
Posted on: 09/02/2014 08:51 AM

The following two Gentoo Linux updates has been released:

[ GLSA 201409-01 ] Wireshark: Multiple vulnerabilities
[ GLSA 201409-02 ] Net-SNMP: Denial of Service

[ GLSA 201409-01 ] Wireshark: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201409-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Wireshark: Multiple vulnerabilities
Date: September 01, 2014
Bugs: #519014
ID: 201409-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Wireshark which could allow
remote attackers to cause Denial of Service.

Background
==========

Wireshark is a network protocol analyzer formerly known as ethereal.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-analyzer/wireshark < 1.10.9 >= 1.10.9

Description
===========

Multiple vulnerabilities have been discovered in Wireshark. Please
review the CVE identifiers referenced below for details.

Impact
======

A remote attacker can cause a Denial of Service condition via specially
crafted packets.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Wireshark users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-analyzer/wireshark-1.10.9"

References
==========

[ 1 ] CVE-2014-5161
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-5161
[ 2 ] CVE-2014-5162
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-5162
[ 3 ] CVE-2014-5163
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-5163
[ 4 ] CVE-2014-5164
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-5164
[ 5 ] CVE-2014-5165
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-5165

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201409-01.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




[ GLSA 201409-02 ] Net-SNMP: Denial of Service
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201409-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Net-SNMP: Denial of Service
Date: September 01, 2014
Bugs: #431752, #493296, #502968, #509110
ID: 201409-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Net-SNMP which could allow
remote attackers to cause Denial of Service.

Background
==========

Net-SNMP bundles software for generating and retrieving SNMP data.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-analyzer/net-snmp < 5.7.3_pre3 >= 5.7.3_pre3

Description
===========

Multiple vulnerabilities have been discovered in Net-SNMP. Please
review the CVE identifiers referenced below for details.

Impact
======

A remote attacker could create a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All net-snmp users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot -v ">=net-analyzer/net-snmp-5.7.3_pre3"

References
==========

[ 1 ] CVE-2012-2141
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2141
[ 2 ] CVE-2012-6151
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-6151
[ 3 ] CVE-2014-2284
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2284
[ 4 ] CVE-2014-2285
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2285

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201409-02.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5







Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/wiresharknet_snmp_updates_for_gentoo.html)