WebKitGTK+ 2.19.4 released
Posted on: 01/09/2018 01:49 PM

WebKitGTK+ 2.19.4 has been released. This is a development release leading toward 2.20 series.

WebKitGTK+ 2.19.4 released


WebKitGTK+ is the GNOME platform port of the WebKit rendering engine. Offering WebKit's full functionality through a set of GObject-based APIs, it is suitable for projects requiring any kind of web integration, from hybrid HTML/CSS applications to full-fledged web browsers.

What's new in WebKitGTK+ 2.19.4

- Add web process API to detect when form is submitted via JavaScript.
- Add new API to replace webkit_form_submission_request_get_text_fields() that is now deprecated.
- Add WebKitWebView::web-process-terminated signal and deprecate web-process-crashed.
- Fix rendering issues when editing text areas.
- Use FastMalloc based GstAllocator for GStreamer.
- Fix several crashes and rendering issues.
- Translation updates: Swedish.

Requirements

gtk+ >= 3.6.0
glib >= 2.36
libsoup >= 2.42.0
cairo >= 1.10.2
libxml >= 2.8.0
libxslt >= 1.1.7
HarfBuzz >= 0.9.2
icu
fontconfig >= 2.8.0
FreeType2 >= 2.4.2
libsecret
SQLite
enchant

Depending on your configuration options WebKitGTK+ may also depend on:

gtk+ >= 2.24.10
GObject introspection
gstreamer
GeoClue >= 2.1.5
gudev
cairo-gl >= 1.10.2

Download

https://webkitgtk.org/releases/webkitgtk-2.19.4.tar.xz (15.8MB)
md5sum: b3ca3e7ef6b2bc96257aea562d528ae7
sha1sum: ca70d8827943fdd3545cc1ecbbbe8f14dc1d095c
sha256sum: ab72d78d0e022d8deede56eebabe32e5665a312cecc1de28c16af9ca713d115a



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/webkitgtk_2_19_4_released.html)