WebKitGTK+ 2.18.0 released
Posted on: 09/11/2017 09:41 AM

WebKitGTK+ 2.18.0 has been released. This is the first stable release in the 2.18 series

WebKitGTK+ 2.18.0 released


WebKitGTK+ is the GNOME platform port of the WebKit rendering engine. Offering WebKit's full functionality through a set of GObject-based APIs, it is suitable for projects requiring any kind of web integration, from hybrid HTML/CSS applications to full-fledged web browsers.

What's new in 2.18.0:

- Initial WebDriver support.
- New remote inspector infrastructure.
- WebCrypto API support is now enabled by default.
- GStreamerGL is enabled by default when building with GStreamer >= 1.10.
- Kinetic scrolling support.
- New API to create a WebKitContextMenuItem from a GAction.
- New API to allow overriding the popup menu of select elements.

Requirements:

gtk+ >= 3.6.0
glib >= 2.36
libsoup >= 2.42.0
cairo >= 1.10.2
libxml >= 2.8.0
libxslt >= 1.1.7
HarfBuzz >= 0.9.2
icu
fontconfig >= 2.8.0
FreeType2 >= 2.4.2
libsecret
SQLite
enchant

Depending on your configuration options WebKitGTK+ may also depend on:

gtk+ >= 2.24.10
GObject introspection
gstreamer >= 1.2.3
GeoClue >= 2.1.5
gudev
cairo-gl >= 1.10.2

Download:

https://webkitgtk.org/releases/webkitgtk-2.18.0.tar.xz (14.1MB)
md5sum: 10d86dd5a5b68875654cc38af139f382
sha1sum: e4d6cc7cff8729aa5ae6c17e10ed5ddf31048983
sha256sum: b583e46a3de36a3e80ba33b084ead60512a2046aca01ff61e50e519436e5038d



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/webkitgtk_2_18_released.html)