USN-8-1: gaim vulnerabilities
Posted on: 10/27/2004 05:39 AM

A gaim security update has been released for Ubuntu Linux

Ubuntu Security Notice USN-8-1 October 27, 2004
gaim vulnerabilities

A security issue affects the following Ubuntu releases:

Ubuntu 4.10 (Warty Warthog)

The following packages are affected:


The problem can be corrected by upgrading the affected package to version 1:1.0.0-1ubuntu1.1. In general, a standard system upgrade is sufficient to effect the necessary changes.

Details follow:

A buffer overflow and two remote crashes were recently discovered in gaim's MSN protocol handler. An attacker could potentially execute arbitrary code with the user's privileges by crafting and sending a particular MSN message.

Source archives:
Size/MD5: 40716 a1cd244a1d9197c9a4855706f857ede2
Size/MD5: 853 dbd5a82e0fa2c33df8fc26d636a2f9f1
Size/MD5: 6985979 7dde686aace751a49dce734fd0cb7ace

amd64 architecture (Athlon64, Opteron, EM64T Xeon)
Size/MD5: 3443672 0a2a22b071c0256a2d68d20b474fdddc

i386 architecture (x86 compatible Intel/AMD)
Size/MD5: 3353616 1b825ce8a2cbba5fa2171fa089f71112

powerpc architecture (Apple Macintosh G3/G4/G5)
Size/MD5: 3417684 bae36e86bcf49722af6497d55a2de5fc

Printed from Linux Compatible (