USN-81-1: iptables vulnerability
Posted on: 02/11/2005 08:07 AM

An iptables update has been released for Ubuntu Linux 4.10

==========================================================
Ubuntu Security Notice USN-81-1 February 11, 2005
iptables vulnerability
CAN-2004-0986
==========================================================

A security issue affects the following Ubuntu releases:

Ubuntu 4.10 (Warty Warthog)

The following packages are affected:

iptables

The problem can be corrected by upgrading the affected package to version 1.2.9-10ubuntu0.1. After a standard system upgrade you have to restart your firewall to ensure that the necessary changes take effect.

Details follow:

Faheem Mitha noticed that the "iptables" command did not always load the required modules on its own as it was supposed to. This could lead to firewall rules not being loaded on system startup.

Source archives:

http://security.ubuntu.com/ubuntu/pool/main/i/iptables/iptables_1.2.9-10ubuntu0.1.dsc
Size/MD5: 568 4bbc3d324b3ce66ac020b0cdc16b38e3
http://security.ubuntu.com/ubuntu/pool/main/i/iptables/iptables_1.2.9-10ubuntu0.1.tar.gz
Size/MD5: 822914 cb740cad8d87e79c9657b3c88b79a506

amd64 architecture (Athlon64, Opteron, EM64T Xeon)

http://security.ubuntu.com/ubuntu/pool/main/i/iptables/iptables-dev_1.2.9-10ubuntu0.1_amd64.deb
Size/MD5: 130702 528d690fb34b13bd819ce8dc35308149
http://security.ubuntu.com/ubuntu/pool/main/i/iptables/iptables_1.2.9-10ubuntu0.1_amd64.deb
Size/MD5: 398986 a3e05e2ff3b923c5d39cabd6abd2c53d

i386 architecture (x86 compatible Intel/AMD)

http://security.ubuntu.com/ubuntu/pool/main/i/iptables/iptables-dev_1.2.9-10ubuntu0.1_i386.deb
Size/MD5: 122724 50c22358f071c301e9807a566df800de
http://security.ubuntu.com/ubuntu/pool/main/i/iptables/iptables_1.2.9-10ubuntu0.1_i386.deb
Size/MD5: 345656 1e4f5cecaa84b8a67d3c1ee42629311b

powerpc architecture (Apple Macintosh G3/G4/G5)

http://security.ubuntu.com/ubuntu/pool/main/i/iptables/iptables-dev_1.2.9-10ubuntu0.1_powerpc.deb
Size/MD5: 131672 2d56e4299d447727302003ca9ae5a612
http://security.ubuntu.com/ubuntu/pool/main/i/iptables/iptables_1.2.9-10ubuntu0.1_powerpc.deb
Size/MD5: 389140 06e9eea393433d82a2979fbead2243a9


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/usn_81_1_iptables_vulnerability.html)