USN-49-1: debmake vulnerability
Posted on: 12/23/2004 07:57 AM

A debmake security update has been released for Ubuntu Linux 4.10

Ubuntu Security Notice USN-49-1 December 23, 2004
debmake vulnerability

A security issue affects the following Ubuntu releases:

Ubuntu 4.10 (Warty Warthog)

The following packages are affected:


The problem can be corrected by upgrading the affected package to version 3.7.4ubuntu0.1. In general, a standard system upgrade is sufficient to effect the necessary changes.

Details follow:

Javier Fernendez-Sanguino Pefa noticed that the debstd script from debmake, a deprecated helper package for Debian packaging, created temporary directories in an insecure manner. This could allow a symlink attack to create or overwrite arbitrary files with the privileges of the user invoking the program.

Source archives:
Size/MD5: 565 530fc54f928a366dfbec2188ac5bd2d7
Size/MD5: 40185 4f465bc55202b85579283f0a6e48a07c

Architecture independent packages:
Size/MD5: 44686 85d26bbc8e69cb24b8f3e6b5632f4814

Printed from Linux Compatible (