USN-45-1: nasm vulnerability
Posted on: 12/22/2004 05:15 PM

A nasm security update has been released for Ubuntu Linux

Ubuntu Security Notice USN-45-1 December 22, 2004
nasm vulnerability

A security issue affects the following Ubuntu releases:

Ubuntu 4.10 (Warty Warthog)

The following packages are affected:


The problem can be corrected by upgrading the affected package to version 0.98.38-1ubuntu0.1. In general, a standard system upgrade is sufficient to effect the necessary changes.

Details follow:

Jonathan Rockway discovered a locally exploitable buffer overflow in the error() function of nasm. If an attacker tricked a user into assembling a malicious source file, they could exploit this to execute arbitrary code with the privileges of the user that runs nasm.

Source archives:
Size/MD5: 9013 69265719926bba4907e7da4df681324d
Size/MD5: 598 b160f2ca70fc5bd4021c1e6e526eaf70
Size/MD5: 641727 9c1df91560651cbfaa73595fe6babb85

amd64 architecture (Athlon64, Opteron, EM64T Xeon)
Size/MD5: 1586664 2c76de8992b04548754487c9a2aa61dd

i386 architecture (x86 compatible Intel/AMD)
Size/MD5: 1545538 a9c5d4e5a11f9c0c36a1deb5754eaf68

powerpc architecture (Apple Macintosh G3/G4/G5)
Size/MD5: 1584374 540e0c417178d47713ca0cd60b7fc806

Printed from Linux Compatible (