USN-434-1: Ekiga vulnerability
Posted on: 03/09/2007 05:30 AM

A new Ekiga vulnerability update is available for Ubuntu Linux. Here the announcement:

Ubuntu Security Notice USN-434-1 March 09, 2007
ekiga, gnomemeeting vulnerability
CVE-2007-0999
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D

A security issue affects the following Ubuntu releases:

Ubuntu 5.10
Ubuntu 6.06 LTS
Ubuntu 6.10

This advisory also applies to the corresponding versions of
Kubuntu, Edubuntu, and Xubuntu.

The problem can be corrected by upgrading your system to the
following package versions:

Ubuntu 5.10:
gnomemeeting 1.2.2-1ubuntu1.2

Ubuntu 6.06 LTS:
ekiga 2.0.1-0ubuntu6.2

Ubuntu 6.10:
ekiga 2.0.3-0ubuntu3.2

After a standard system upgrade you need to restart Ekiga or reboot your=20
computer to effect the necessary changes.

Details follow:

It was discovered that Ekiga had format string vulnerabilities beyond=20
those fixed in USN-426-1. If a user was running Ekiga and listening for=20
incoming calls, a remote attacker could send a crafted call request, and=20
execute arbitrary code with the user's privileges.


Updated packages for Ubuntu 5.10:

Source archives:

http://security.ubuntu.com/ubuntu/pool/main/g/gnomemeeting/gnomemeeting=
_1.2.2-1ubuntu1.2.diff.gz
Size/MD5: 13935 390ded46c12911e6ff7f0fb0b41648b1
http://security.ubuntu.com/ubuntu/pool/main/g/gnomemeeting/gnomemeeting=
_1.2.2-1ubuntu1.2.dsc
Size/MD5: 1811 bfaea7c58d0be1c76fb15275584929d8
http://security.ubuntu.com/ubuntu/pool/main/g/gnomemeeting/gnomemeeting=
_1.2.2.orig.tar.gz
Size/MD5: 6059950 65fe2d6a31e63a37c5a6217206223192

amd64 architecture (Athlon64, Opteron, EM64T Xeon)

http://security.ubuntu.com/ubuntu/pool/main/g/gnomemeeting/gnomemeeting=
_1.2.2-1ubuntu1.2_amd64.deb
Size/MD5: 1826502 ab68c7c0c54d6ea2288058f1cd850e0a

i386 architecture (x86 compatible Intel/AMD)

http://security.ubuntu.com/ubuntu/pool/main/g/gnomemeeting/gnomemeeting=
_1.2.2-1ubuntu1.2_i386.deb
Size/MD5: 1802224 2323471938830841421f5758518444a0

powerpc architecture (Apple Macintosh G3/G4/G5)

http://security.ubuntu.com/ubuntu/pool/main/g/gnomemeeting/gnomemeeting=
_1.2.2-1ubuntu1.2_powerpc.deb
Size/MD5: 1817578 61f4574c015fb133a7d223d68945ad87

sparc architecture (Sun SPARC/UltraSPARC)

http://security.ubuntu.com/ubuntu/pool/main/g/gnomemeeting/gnomemeeting=
_1.2.2-1ubuntu1.2_sparc.deb
Size/MD5: 1803946 ab636f2081b328f36025e99cea2f0cd3

Updated packages for Ubuntu 6.06 LTS:

Source archives:

http://security.ubuntu.com/ubuntu/pool/main/e/ekiga/ekiga_2.0.1-0ubuntu=
6.2.diff.gz
Size/MD5: 26736 820ab04b4cb0423bb9d62f03bf3e4634
http://security.ubuntu.com/ubuntu/pool/main/e/ekiga/ekiga_2.0.1-0ubuntu=
6.2.dsc
Size/MD5: 2090 921caa6df4e1ceeb79438b5f653992c6
http://security.ubuntu.com/ubuntu/pool/main/e/ekiga/ekiga_2.0.1.orig.ta=
r.gz
Size/MD5: 5572709 9f0a2bcce380677e38b23991320df171

amd64 architecture (Athlon64, Opteron, EM64T Xeon)

http://security.ubuntu.com/ubuntu/pool/main/e/ekiga/ekiga_2.0.1-0ubuntu=
6.2_amd64.deb
Size/MD5: 3687974 428c44b190d3e1e6f97f8d3be08aa6fe

i386 architecture (x86 compatible Intel/AMD)

http://security.ubuntu.com/ubuntu/pool/main/e/ekiga/ekiga_2.0.1-0ubuntu=
6.2_i386.deb
Size/MD5: 3658256 2b4c80838f881af9780e65e5be79b26b

powerpc architecture (Apple Macintosh G3/G4/G5)

http://security.ubuntu.com/ubuntu/pool/main/e/ekiga/ekiga_2.0.1-0ubuntu=
6.2_powerpc.deb
Size/MD5: 3673874 44119593cb37df9ae0c759df26e9f5b3

sparc architecture (Sun SPARC/UltraSPARC)

http://security.ubuntu.com/ubuntu/pool/main/e/ekiga/ekiga_2.0.1-0ubuntu=
6.2_sparc.deb
Size/MD5: 3661004 85ce6c1bc136e1e6699cfb501d537abd

Updated packages for Ubuntu 6.10:

Source archives:

http://security.ubuntu.com/ubuntu/pool/main/e/ekiga/ekiga_2.0.3-0ubuntu=
3.2.diff.gz
Size/MD5: 27205 ae82839a944aa39b118b1fa6edda3f1c
http://security.ubuntu.com/ubuntu/pool/main/e/ekiga/ekiga_2.0.3-0ubuntu=
3.2.dsc
Size/MD5: 1837 90fa46619ab136f7e8d7086916c1bdc0
http://security.ubuntu.com/ubuntu/pool/main/e/ekiga/ekiga_2.0.3.orig.ta=
r.gz
Size/MD5: 5749938 5ad3458d73d65c6502c312ff0c430a7c

amd64 architecture (Athlon64, Opteron, EM64T Xeon)

http://security.ubuntu.com/ubuntu/pool/main/e/ekiga/ekiga_2.0.3-0ubuntu=
3.2_amd64.deb
Size/MD5: 3689026 82e52fe078d8ab0102bf647d12cfe4cc

i386 architecture (x86 compatible Intel/AMD)

http://security.ubuntu.com/ubuntu/pool/main/e/ekiga/ekiga_2.0.3-0ubuntu=
3.2_i386.deb
Size/MD5: 3668638 4ebd1951ef9e4cc4860223e682c90541

powerpc architecture (Apple Macintosh G3/G4/G5)

http://security.ubuntu.com/ubuntu/pool/main/e/ekiga/ekiga_2.0.3-0ubuntu=
3.2_powerpc.deb
Size/MD5: 3676386 efcac25a055bb4cd5e776550c370880f

sparc architecture (Sun SPARC/UltraSPARC)

http://security.ubuntu.com/ubuntu/pool/main/e/ekiga/ekiga_2.0.3-0ubuntu=
3.2_sparc.deb
Size/MD5: 3671020 41fda4e546004b1a7f456b286e2ce560


--MzdA25v054BPvyZa
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFF8OGFH/9LqRcGPm0RAkXDAJ4qmQ2sZB9drDJ510DMnQJlUTA6swCfRIGm
WEdQhbabAeMeW3TSUay0STA=
=lzVk
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/usn_434_1_ekiga_vulnerability.html)