USN-285-1: awstats vulnerability
Posted on: 05/23/2006 10:42 AM

A new awstats vulnerability update is available for Ubuntu Linux. Here the announcement:

Ubuntu Security Notice USN-285-1 May 23, 2006
awstats vulnerability

A security issue affects the following Ubuntu releases:

Ubuntu 5.04 (Hoary Hedgehog)
Ubuntu 5.10 (Breezy Badger)

The following packages are affected:


The problem can be corrected by upgrading the affected package to
version 6.3-1ubuntu0.2 (for Ubuntu 5.04), or 6.4-1ubuntu1.1 (for
Ubuntu 5.10). In general, a standard system upgrade is sufficient to
effect the necessary changes.

Details follow:

AWStats did not properly sanitize the 'migrate' CGI parameter. If the
update of the stats via web front-end is allowed, a remote attacker
could execute arbitrary commands on the server with the privileges of
the AWStats server.

This does not affect AWStats installations which only build static

Updated packages for Ubuntu 5.04:

Source archives:
Size/MD5: 25306 1f013ca8aaad65d8f3ae148e194b3551
Size/MD5: 595 46a103a327e1f1bad3876927c7e66198
Size/MD5: 938794 edb73007530a5800d53b9f1f90c88053

Architecture independent packages:
Size/MD5: 726430 728ee50f468a4cf3693a32b98c94b455

Updated packages for Ubuntu 5.10:

Source archives:
Size/MD5: 18541 e186b842fbd2d4d97b65eacf7c9c1295
Size/MD5: 595 c5784c2c1bfa002abbfa77d936bc2da5
Size/MD5: 918435 056e6fb0c7351b17fe5bbbe0aa1297b1

Architecture independent packages:
Size/MD5: 728490 60ca39a436e3a21a838560db5d8a5f3b

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.4.2.2 (GNU/Linux)


Printed from Linux Compatible (