USN-24-1: openssl script vulnerability
Posted on: 11/11/2004 06:35 PM

An OpenSSL security update is available for Ubuntu Linux 4.10

Ubuntu Security Notice USN-24-1 November 11, 2004
openssl script vulnerability

A security issue affects the following Ubuntu releases:

Ubuntu 4.10 (Warty Warthog)

The following packages are affected:


The problem can be corrected by upgrading the affected package to version 0.9.7d-3ubuntu0.1. In general, a standard system upgrade is sufficient to effect the necessary changes.

Details follow:

Recently, Trustix Secure Linux discovered a vulnerability in the openssl package. The auxiliary script "der_chop" created temporary files in an insecure way, which could allow a symlink attack to create or overwrite arbitrary files with the privileges of the user invoking the program.

Source archives:
Size/MD5: 25295 881c617310b90b1a23170c3af67b1326
Size/MD5: 636 9ac30cc189e6af361873ef8bbae464de
Size/MD5: 2799796 533b7f758325d74c1e01e67994e3ae59

amd64 architecture (Athlon64, Opteron, EM64T Xeon)
Size/MD5: 2676308 b01867418c6f2a038be827927fdd00aa
Size/MD5: 696844 18ab0899bd1532f1ad91f41dd65f08d4
Size/MD5: 899612 711904323e819ac90f7aad08f1bc3631

i386 architecture (x86 compatible Intel/AMD)
Size/MD5: 2477088 8914e8d13dc84b1756bec1c4b19ac2a5
Size/MD5: 2152878 ff51693973742936138ad42c90fb065e
Size/MD5: 898268 adb9c7c755a144f8c5a8bc1bdc157b44

powerpc architecture (Apple Macintosh G3/G4/G5)
Size/MD5: 2759022 1d316d0e83b4b4686d91a7e92512c6ca
Size/MD5: 700616 aef52c3c1fdeaa12773691b3bac4f57d
Size/MD5: 904250 b2b9f62f80982a8ea6d20ce5fc06884d

Printed from Linux Compatible (