USN-243-1: tuxpaint vulnerability
Posted on: 01/16/2006 01:12 PM

A new tuxpaint vulnerability update is available for Ubuntu Linux. Here the announcement:

Ubuntu Security Notice USN-243-1 January 16, 2006
tuxpaint vulnerability
CVE-2005-3340
==========================
==========================
=========

A security issue affects the following Ubuntu releases:

Ubuntu 5.10 (Breezy Badger)

The following packages are affected:

tuxpaint

The problem can be corrected by upgrading the affected package to
version 1:0.9.14-2ubuntu0.1. In general, a standard system upgrade is
sufficient to effect the necessary changes.

Details follow:

Javier Fernández-Sanguino Peña discovered that the tuxpaint-import.sh
script created a temporary file in an insecure way. This could allow a
symlink attack to create or overwrite arbitrary files with the
privileges of the user running tuxpaint.


Source archives:

http://security.ubuntu.com/ubuntu/pool/main/t/tuxpaint/tuxpaint_0.9.14-=
2ubuntu0.1.diff.gz
Size/MD5: 6127 109a598848fcaa2fd23f4b32f5478d79
http://security.ubuntu.com/ubuntu/pool/main/t/tuxpaint/tuxpaint_0.9.14-=
2ubuntu0.1.dsc
Size/MD5: 755 1b27685235065548832add6c65f6d638
http://security.ubuntu.com/ubuntu/pool/main/t/tuxpaint/tuxpaint_0.9.14.=
orig.tar.gz
Size/MD5: 3208894 0b7522c1b3672d5c233f7bbc772c8dec

Architecture independent packages:

http://security.ubuntu.com/ubuntu/pool/main/t/tuxpaint/tuxpaint-data_0.=
9.14-2ubuntu0.1_all.deb
Size/MD5: 1004980 ebc69ca71f5d5cd7fc5f9983d17656d6

amd64 architecture (Athlon64, Opteron, EM64T Xeon)

http://security.ubuntu.com/ubuntu/pool/main/t/tuxpaint/tuxpaint_0.9.14-=
2ubuntu0.1_amd64.deb
Size/MD5: 98728 7211b8041bdadb65e5c15c9f8f7e377d

i386 architecture (x86 compatible Intel/AMD)

http://security.ubuntu.com/ubuntu/pool/main/t/tuxpaint/tuxpaint_0.9.14-=
2ubuntu0.1_i386.deb
Size/MD5: 91672 63ec1209cf7f89213a29fbbb5ab7b570

powerpc architecture (Apple Macintosh G3/G4/G5)

http://security.ubuntu.com/ubuntu/pool/main/t/tuxpaint/tuxpaint_0.9.14-=
2ubuntu0.1_powerpc.deb
Size/MD5: 100306 eb0d05c193c4f40ddb54c1dc03f7d451

--8S1fMsFYqgBC+BN/
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDy4hzDecnbV4Fd/IRAtfSAKCpoyV+8NGeMoavUDpmDS13xuIksACgucrM
keV2yszqZM+BaRik1G6niMM=
=FI6O
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/usn_243_1_tuxpaint_vulnerability.html)