Updated XFree86 package for Red Hat 9
Posted on: 11/20/2003 05:29 AM

Updated XFree86 packages for Red Hat Linux 9 provide security fixes to font libraries and XDM.

XFree86 is an implementation of the X Window System providing the coregraphical user interface and video drivers in Red Hat Linux. XDM is the Xdisplay manager. Multiple integer overflows in the transfer and enumeration of fontlibraries in XFree86 allow local or remote attackers to cause a denial ofservice or execute arbitrary code via heap-based and stack-based bufferoverflow attacks. The Common Vulnerabilities and Exposures project(cve.mitre.org) has assigned the name CAN-2003-0730 to this issue. The risk to users from this vulnerability is limited because only clientscan be affected by these bugs, however in some (non-default) configurations, both xfs and the X Server can act as clientsto remote font servers. XDM does not verify whether the pam_setcred function call succeeds, which may allow attackers to gain root privileges by triggering error conditions within PAM modules, as demonstrated in certain configurations of thepam_krb5 module. The Common Vulnerabilities and Exposures project(cve.mitre.org) has assigned the name CAN-2003-0690 to this issue. XDM uses a weak session cookie generation algorithm that does not provide 128 bits of entropy, which allows attackers to guess session cookies via brute force methods and gain access to the user session. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2003-0692 to this issue. Users are advised to upgrade to these updated XFree86 4.3.0 packages, whichcontain backported security patches and are not vulnerable to these issues.

Read more


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/updated_xfree86_package_for_red_hat_9.html)