Smarty3 Security Update for Debian 8/9
Posted on: 01/23/2018 09:10 AM

Updated smarty3 packages has been released for Debian GNU/Linux 8 and 9

Smarty3 Security Update for Debian 8/9


- -------------------------------------------------------------------------
Debian Security Advisory DSA-4094-1 security@debian.org
https://www.debian.org/security/
January 22, 2018 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : smarty3
CVE ID : CVE-2017-1000480
Debian Bug : 886460

It was discovered that Smarty, a PHP template engine, was vulnerable to
code-injection attacks. An attacker was able to craft a filename in
comments that could lead to arbitrary code execution on the host running
Smarty.

For the oldstable distribution (jessie), this problem has been fixed
in version 3.1.21-1+deb8u1.

For the stable distribution (stretch), this problem has been fixed in
version 3.1.31+20161214.1.c7d42e4+selfpack1-2+deb9u1.

We recommend that you upgrade your smarty3 packages.

For the detailed security status of smarty3 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/smarty3

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/




Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/smarty3_security_update_for_debian_89.html)