Shibboleth-sp2/OpenSaml2 Updates for Debian 8/9
Posted on: 11/17/2017 05:32 AM

The following security updates has been released for Debian GNU/Linux 8 and 9:

DSA 4038-1: shibboleth-sp2 security update
DSA 4039-1: opensaml2 security update

DSA 4038-1: shibboleth-sp2 security update



- -------------------------------------------------------------------------
Debian Security Advisory DSA-4038-1 security@debian.org
https://www.debian.org/security/ Salvatore Bonaccorso
November 16, 2017 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : shibboleth-sp2
CVE ID : CVE-2017-16852
Debian Bug : 881857

Rod Widdowson of Steading System Software LLP discovered a coding error
in the "Dynamic" metadata plugin of the Shibboleth Service Provider,
causing the plugin to fail configuring itself with the filters provided
and omitting whatever checks they are intended to perform.

For the oldstable distribution (jessie), this problem has been fixed
in version 2.5.3+dfsg-2+deb8u1.

For the stable distribution (stretch), this problem has been fixed in
version 2.6.0+dfsg1-4+deb9u1.

We recommend that you upgrade your shibboleth-sp2 packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/




DSA 4039-1: opensaml2 security update



- -------------------------------------------------------------------------
Debian Security Advisory DSA-4039-1 security@debian.org
https://www.debian.org/security/ Salvatore Bonaccorso
November 16, 2017 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : opensaml2
CVE ID : CVE-2017-16853
Debian Bug : 881856

Rod Widdowson of Steading System Software LLP discovered a coding error
in the OpenSAML library, causing the DynamicMetadataProvider class to
fail configuring itself with the filters provided and omitting whatever
checks they are intended to perform.

For the oldstable distribution (jessie), this problem has been fixed
in version 2.5.3-2+deb8u2.

For the stable distribution (stretch), this problem has been fixed in
version 2.6.0-4+deb9u1.

We recommend that you upgrade your opensaml2 packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/







Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/shibboleth_sp2opensaml2_updates_for_debian_89.html)