[Security Announce] [ MDKSA-2007:216 ] - Updated kernel packages fix multiple vulnerabilities and bugs
Posted on: 11/14/2007 08:40 AM

The Mandriva Security Team published a new security update for Mandriva Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDKSA-2007:216
http://www.mandriva.com/security/
_______________________________________________________________________

Package : kernel
Date : November 13, 2007
Affected: Corporate 3.0, Multi Network Firewall 2.0
_______________________________________________________________________

Problem Description:

Some vulnerabilities were discovered and corrected in the Linux
2.6 kernel:

A typo in the Linux kernel caused RTA_MAX to be used as an array size
instead of RTN_MAX, which lead to an out of bounds access by certain
functions (CVE-2007-2172).

The IPv6 protocol allowed remote attackers to cause a denial of
service via crafted IPv6 type 0 route headers that create network
amplification between two routers (CVE-2007-2242).

The random number feature did not properly seed pools when there was
no entropy, or used an incorrect cast when extracting entropy, which
could cause the random number generator to provide the same values
after reboots on systems without an entropy source (CVE-2007-2453).

A memory leak in the PPPoE socket implementation allowed local users
to cause a denial of service (memory consumption) by creating a
socket using connect, and releasing it before the PPPIOCGCHAN ioctl
is initialized (CVE-2007-2525).

A stack-based buffer overflow in the random number generator could
allow local root users to cause a denial of service or gain privileges
by setting the default wakeup threshold to a value greater than the
output pool size (CVE-2007-3105).

The hugetlb_vmtruncate_list() and hugetlb_vmtruncate() functions in the
Linux kernel perform certain pio_tree calculations using HPAGE_SIZE
intead of PAGE_SIZE units, which may allow local users to cause a
denial of service (panic) via unspecified vectors (CVE-2007-4133).

To update your kernel, please follow the directions located at:

http://www.mandriva.com/en/security/kernelupdate
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-2172
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-2242
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-2453
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-2525
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-3105
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-4133
_______________________________________________________________________

Updated Packages:

Corporate 3.0:
951b74d57e994b4628145efacc37222c corporate/3.0/i586/kernel-2.6.3.37mdk-1-1mdk.i586.rpm
86de2411fb8c3d140849b8acdb2ddf6e corporate/3.0/i586/kernel-BOOT-2.6.3.37mdk-1-1mdk.i586.rpm
cdf5a2817b915da2da45f9437ec8d38f corporate/3.0/i586/kernel-doc-2.6.3-37mdk.i586.rpm
59d21423ef81ff35dddad9001fda3642 corporate/3.0/i586/kernel-enterprise-2.6.3.37mdk-1-1mdk.i586.rpm
9d1434bd62398cf5dcaab7415f147277 corporate/3.0/i586/kernel-i686-up-4GB-2.6.3.37mdk-1-1mdk.i586.rpm
a529c6992a35891bc520d3ad890cbf12 corporate/3.0/i586/kernel-p3-smp-64GB-2.6.3.37mdk-1-1mdk.i586.rpm
3d2a8f68700537c645640f5306ca8960 corporate/3.0/i586/kernel-secure-2.6.3.37mdk-1-1mdk.i586.rpm
be4214847382dc6f0d5643f22ddf8f39 corporate/3.0/i586/kernel-smp-2.6.3.37mdk-1-1mdk.i586.rpm
e2689b9b306664d765d862c0daede5d5 corporate/3.0/i586/kernel-source-2.6.3-37mdk.i586.rpm
008504eda8fed1c67454cd60c027d028 corporate/3.0/i586/kernel-source-stripped-2.6.3-37mdk.i586.rpm
b9d3ea705a1bef93599196cc49b82542 corporate/3.0/SRPMS/kernel-2.6.3.37mdk-1-1mdk.src.rpm

Corporate 3.0/X86_64:
8169fd11e477ca0b8632c08a7117917e corporate/3.0/x86_64/kernel-2.6.3.37mdk-1-1mdk.x86_64.rpm
cf8eb0161a4546fa607b0d929a1aa0f4 corporate/3.0/x86_64/kernel-BOOT-2.6.3.37mdk-1-1mdk.x86_64.rpm
872f9663d73566764008dd809eec01cf corporate/3.0/x86_64/kernel-doc-2.6.3-37mdk.x86_64.rpm
324a6126fae141784d37ee9d9225d89a corporate/3.0/x86_64/kernel-secure-2.6.3.37mdk-1-1mdk.x86_64.rpm
c91f757553e380aafc8188e7639b6f55 corporate/3.0/x86_64/kernel-smp-2.6.3.37mdk-1-1mdk.x86_64.rpm
7b7ef3e6dcd36a7148f582c22c62640c corporate/3.0/x86_64/kernel-source-2.6.3-37mdk.x86_64.rpm
ff5dbcddb882758fd0f6f74c90b9281a corporate/3.0/x86_64/kernel-source-stripped-2.6.3-37mdk.x86_64.rpm
b9d3ea705a1bef93599196cc49b82542 corporate/3.0/SRPMS/kernel-2.6.3.37mdk-1-1mdk.src.rpm

Multi Network Firewall 2.0:
a5c867fd3c793d8322dc1b126316851f mnf/2.0/i586/kernel-2.6.3.37mdk-1-1mdk.i586.rpm
86082110e7d82931a415bfeae71a1d26 mnf/2.0/i586/kernel-i686-up-4GB-2.6.3.37mdk-1-1mdk.i586.rpm
bb8cd008ed4dce886eef632c2e21fe87 mnf/2.0/i586/kernel-p3-smp-64GB-2.6.3.37mdk-1-1mdk.i586.rpm
998a08ace2f127df5421122ddb3fa66f mnf/2.0/i586/kernel-secure-2.6.3.37mdk-1-1mdk.i586.rpm
14607a9531ab4b2a39ea92290138f2a2 mnf/2.0/i586/kernel-smp-2.6.3.37mdk-1-1mdk.i586.rpm
a7036e1a17abe820d86dd900ca4e9736 mnf/2.0/SRPMS/kernel-2.6.3.37mdk-1-1mdk.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
lt;security*mandriva.comgt;
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)

iD8DBQFHOdFHmqjQ0CJFipgRAtgfAKCLMBxSMsnAEsjZy6wF8XCuzpaJ1QCeOwTm
JuMRcRIfqB8Lx6WlaWPfoR0=
=RW42
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/security_announce_mdksa_2007216__updated_kernel_packages_fix_multiple_vulnerabilities_and_bugs.html)