[Security Announce] [ MDKSA-2007:205 ] - Updated opal packages fix vulnerability
Posted on: 11/03/2007 12:20 AM

The Mandriva Security Team published a new security update for Mandriva Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDKSA-2007:205
http://www.mandriva.com/security/
_______________________________________________________________________

Package : opal
Date : November 2, 2007
Affected: 2007.0, 2007.1
_______________________________________________________________________

Problem Description:

A flaw in opal, the Open Phone Abstraction Library, was found in
how it handles certain Session Initiation Protocol (SIP) packets.
An attacker could use this vulnerability to crash an application
linked to opal, such as Ekiga.

Updated packages have been patched to prevent these issues.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-4924
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2007.0:
337dc6f6f00747d93d833d462b388001 2007.0/i586/libopal2-2.2.3-1.1mdv2007.0.i586.rpm
72b7fa693dcfa0bd9eb947c9efc48089 2007.0/i586/libopal2-devel-2.2.3-1.1mdv2007.0.i586.rpm
ee93a37f7426e9564f93ea526a60f3f6 2007.0/SRPMS/opal-2.2.3-1.1mdv2007.0.src.rpm

Mandriva Linux 2007.0/X86_64:
c4502c7d03ddecd7a2fa0aa788888594 2007.0/x86_64/lib64opal2-2.2.3-1.1mdv2007.0.x86_64.rpm
3acdb9831b86988832032c61de7178b3 2007.0/x86_64/lib64opal2-devel-2.2.3-1.1mdv2007.0.x86_64.rpm
ee93a37f7426e9564f93ea526a60f3f6 2007.0/SRPMS/opal-2.2.3-1.1mdv2007.0.src.rpm

Mandriva Linux 2007.1:
d544b489474818208d00d1a2abcf6821 2007.1/i586/libopal2-2.2.6-1.1mdv2007.1.i586.rpm
689aef82cbaf8bf1a0dbea2e688a44ea 2007.1/i586/libopal2-devel-2.2.6-1.1mdv2007.1.i586.rpm
72fef0012c30c0771b97bc0aadcd47fe 2007.1/SRPMS/opal-2.2.6-1.1mdv2007.1.src.rpm

Mandriva Linux 2007.1/X86_64:
cdaf928352d65caa57c00068467f74e8 2007.1/x86_64/lib64opal2-2.2.6-1.1mdv2007.1.x86_64.rpm
2b6695ed410c7ec3021b7e194d603fca 2007.1/x86_64/lib64opal2-devel-2.2.6-1.1mdv2007.1.x86_64.rpm
72fef0012c30c0771b97bc0aadcd47fe 2007.1/SRPMS/opal-2.2.6-1.1mdv2007.1.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
lt;security*mandriva.comgt;
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)

iD8DBQFHK3NjmqjQ0CJFipgRAh/AAKCP0SfpB/NazxgTgosH0hax2+Q0wgCgliUo
2rwI0LYjW8kpnyHGJA/0dB0=
=svoK
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/security_announce_mdksa_2007205__updated_opal_packages_fix_vulnerability.html)