[Security Announce] [ MDKSA-2007:148 ] - Updated tcpdump packages fix BGP dissector vulnerability
Posted on: 07/25/2007 10:25 PM

The Mandriva Security Team published a new security update for Mandriva Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDKSA-2007:148
http://www.mandriva.com/security/
_______________________________________________________________________

Package : tcpdump
Date : July 25, 2007
Affected: 2007.0, 2007.1, Corporate 3.0, Corporate 4.0
_______________________________________________________________________

Problem Description:

An integer overflow in tcpdump could allow a remote attacker to
execute arbitrary code via crafted TLVs in a BGP packet.

Updated packages have been patched to prevent this issue.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-3798
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2007.0:
73a03979bbb0fef6ecca9cfea8c15293 2007.0/i586/tcpdump-3.9.4-1.2mdv2007.0.i586.rpm
767f8fbcc96602d5e85c1131ca789323 2007.0/SRPMS/tcpdump-3.9.4-1.2mdv2007.0.src.rpm

Mandriva Linux 2007.0/X86_64:
043b7ecea174ab02b651b78a4d163249 2007.0/x86_64/tcpdump-3.9.4-1.2mdv2007.0.x86_64.rpm
767f8fbcc96602d5e85c1131ca789323 2007.0/SRPMS/tcpdump-3.9.4-1.2mdv2007.0.src.rpm

Mandriva Linux 2007.1:
2d152372297a0797eb2f91d5eea15d31 2007.1/i586/tcpdump-3.9.5-1.1mdv2007.1.i586.rpm
15ded4bd5c5d5dfce05348c7eed0a456 2007.1/SRPMS/tcpdump-3.9.5-1.1mdv2007.1.src.rpm

Mandriva Linux 2007.1/X86_64:
0d2602af49e234dbff3cc1cb4f782981 2007.1/x86_64/tcpdump-3.9.5-1.1mdv2007.1.x86_64.rpm
15ded4bd5c5d5dfce05348c7eed0a456 2007.1/SRPMS/tcpdump-3.9.5-1.1mdv2007.1.src.rpm

Corporate 3.0:
3649b10b9d8b03982e40d461bf5f8733 corporate/3.0/i586/tcpdump-3.8.1-1.4.C30mdk.i586.rpm
ec63bb0a8bc2ea06f5f2218c5e0528b7 corporate/3.0/SRPMS/tcpdump-3.8.1-1.4.C30mdk.src.rpm

Corporate 3.0/X86_64:
254d9a3f816f759bacc42e5f24bbc895 corporate/3.0/x86_64/tcpdump-3.8.1-1.4.C30mdk.x86_64.rpm
ec63bb0a8bc2ea06f5f2218c5e0528b7 corporate/3.0/SRPMS/tcpdump-3.8.1-1.4.C30mdk.src.rpm

Corporate 4.0:
51de8a617eeb1ee78dc0c86999911e20 corporate/4.0/i586/tcpdump-3.9.3-1.4.20060mlcs4.i586.rpm
7228692328e815bdd36c34c9c205fd0a corporate/4.0/SRPMS/tcpdump-3.9.3-1.4.20060mlcs4.src.rpm

Corporate 4.0/X86_64:
28924494741b88fd6b3dfdd924e08a96 corporate/4.0/x86_64/tcpdump-3.9.3-1.4.20060mlcs4.x86_64.rpm
7228692328e815bdd36c34c9c205fd0a corporate/4.0/SRPMS/tcpdump-3.9.3-1.4.20060mlcs4.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
lt;security*mandriva.comgt;
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)

iD8DBQFGp20vmqjQ0CJFipgRAmsLAJ0SIow8rgYGHAdd2kOuYYRZEJU5JgCg55ub
Tm6UF+FjCyRy8fGK6kri+PY=
=quRo
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/security_announce_mdksa_2007148__updated_tcpdump_packages_fix_bgp_dissector_vulnerability.html)