[Security Announce] [ MDKSA-2007:143 ] - Updated mplayer packages fix buffer overflow remote vulnerabilities
Posted on: 07/10/2007 03:05 PM

The Mandriva Security Team published a new security update for Mandriva Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDKSA-2007:143
http://www.mandriva.com/security/
_______________________________________________________________________

Package : mplayer
Date : July 10, 2007
Affected: 2007.0, 2007.1, Corporate 3.0
_______________________________________________________________________

Problem Description:

Multiple stack-based buffer overflows in stream/stream_cddb.c in
MPlayer before 1.0rc1try3 allow remote attackers to execute arbitrary
code via a CDDB entry with a long (1) album title or (2) category.

Updated packages have been patched to prevent this issue.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-2948
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2007.0:
25e2f7434923c54e22a15817ec58174e 2007.0/i586/libdha1.0-1.0-1.pre8.13.4mdv2007.0.i586.rpm
a062d432719daa5ba6f1d5d7307a1ba8 2007.0/i586/mencoder-1.0-1.pre8.13.4mdv2007.0.i586.rpm
17a8adca674bece173ea1ddb6301eaa5 2007.0/i586/mplayer-1.0-1.pre8.13.4mdv2007.0.i586.rpm
27ccf8fa2715d44bfe183603767c56a7 2007.0/i586/mplayer-gui-1.0-1.pre8.13.4mdv2007.0.i586.rpm
0cb86683e6e5c38381fb3cd6ccb62240 2007.0/SRPMS/mplayer-1.0-1.pre8.13.4mdv2007.0.src.rpm

Mandriva Linux 2007.0/X86_64:
0eb841778648537762f458fa39e29f6c 2007.0/x86_64/mencoder-1.0-1.pre8.13.4mdv2007.0.x86_64.rpm
51039a3929e9f208fd9e82be957a98de 2007.0/x86_64/mplayer-1.0-1.pre8.13.4mdv2007.0.x86_64.rpm
6288f99b19ff5b871c2183c7c77fea8f 2007.0/x86_64/mplayer-gui-1.0-1.pre8.13.4mdv2007.0.x86_64.rpm
0cb86683e6e5c38381fb3cd6ccb62240 2007.0/SRPMS/mplayer-1.0-1.pre8.13.4mdv2007.0.src.rpm

Mandriva Linux 2007.1:
ef28e39e802fa8a234f86df2ad95c45c 2007.1/i586/libdha1.0-1.0-1.rc1.11.2mdv2007.1.i586.rpm
afe898096241784c90501d8a7a6ccd88 2007.1/i586/mencoder-1.0-1.rc1.11.2mdv2007.1.i586.rpm
9b94c89b98f7f6303bb113873d6c74e2 2007.1/i586/mplayer-1.0-1.rc1.11.2mdv2007.1.i586.rpm
3b4a54447411d32ac010e75943fc5493 2007.1/i586/mplayer-doc-1.0-1.rc1.11.2mdv2007.1.i586.rpm
eedbff57903999e78f3ebc31695fd632 2007.1/i586/mplayer-gui-1.0-1.rc1.11.2mdv2007.1.i586.rpm
9aca58cedd97a632d671e550e2abe3ee 2007.1/SRPMS/mplayer-1.0-1.rc1.11.2mdv2007.1.src.rpm

Mandriva Linux 2007.1/X86_64:
674516b36f851b06ade955dcc2ccdb6c 2007.1/x86_64/mencoder-1.0-1.rc1.11.2mdv2007.1.x86_64.rpm
bf5722fa05f82f79e298830226a995fd 2007.1/x86_64/mplayer-1.0-1.rc1.11.2mdv2007.1.x86_64.rpm
910a0878c17d0f936b6e669032bc6d36 2007.1/x86_64/mplayer-doc-1.0-1.rc1.11.2mdv2007.1.x86_64.rpm
c572ce827d290621654bd8c57587f76d 2007.1/x86_64/mplayer-gui-1.0-1.rc1.11.2mdv2007.1.x86_64.rpm
9aca58cedd97a632d671e550e2abe3ee 2007.1/SRPMS/mplayer-1.0-1.rc1.11.2mdv2007.1.src.rpm

Corporate 3.0:
34534b724ef48b53d706949f448978ad corporate/3.0/i586/libdha0.1-1.0-0.pre3.14.12.C30mdk.i586.rpm
7f60b9f3ef33ea7e2f131d570c658d10 corporate/3.0/i586/libpostproc0-1.0-0.pre3.14.12.C30mdk.i586.rpm
bd302e5db44860753ada86b1229a8d5d corporate/3.0/i586/libpostproc0-devel-1.0-0.pre3.14.12.C30mdk.i586.rpm
828c20f259283b69aadf064c56fad11f corporate/3.0/i586/mencoder-1.0-0.pre3.14.12.C30mdk.i586.rpm
cb41721c4bb550af139ac3b8e44d73a6 corporate/3.0/i586/mplayer-1.0-0.pre3.14.12.C30mdk.i586.rpm
0df3b055e8dec142b7041d3e2454688b corporate/3.0/i586/mplayer-gui-1.0-0.pre3.14.12.C30mdk.i586.rpm
15197a8db2b41eb6051e976c5411341a corporate/3.0/SRPMS/mplayer-1.0-0.pre3.14.12.C30mdk.src.rpm

Corporate 3.0/X86_64:
f74386a58305e0f50cdbecbcd5c3f0b3 corporate/3.0/x86_64/lib64postproc0-1.0-0.pre3.14.12.C30mdk.x86_64.rpm
656b76d2ad1fdd78daaa5bca0a3d014f corporate/3.0/x86_64/lib64postproc0-devel-1.0-0.pre3.14.12.C30mdk.x86_64.rpm
de8581bfb537adaac8a0eb47f96fe4bd corporate/3.0/x86_64/mencoder-1.0-0.pre3.14.12.C30mdk.x86_64.rpm
5a4e7cccb601485889ed3619492ec839 corporate/3.0/x86_64/mplayer-1.0-0.pre3.14.12.C30mdk.x86_64.rpm
f3ea84ee2e18f7457674daff97646bb1 corporate/3.0/x86_64/mplayer-gui-1.0-0.pre3.14.12.C30mdk.x86_64.rpm
15197a8db2b41eb6051e976c5411341a corporate/3.0/SRPMS/mplayer-1.0-0.pre3.14.12.C30mdk.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
lt;security*mandriva.comgt;
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)

iD8DBQFGky0GmqjQ0CJFipgRAlMNAJ9S0Y8nRlK9mZR9yDn8oQ3C7KiSTwCgt2w2
jRuM+Q/iusy2bfe9XlHXCxU=
=NSYO
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/security_announce_mdksa_2007143__updated_mplayer_packages_fix_buffer_overflow_remote_vulnerabilities.html)