[Security Announce] [ MDKSA-2007:135 ] - Updated webmin packages fix XSS vulnerability
Posted on: 06/23/2007 01:30 AM

The Mandriva Security Team published a new security update for Mandriva Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDKSA-2007:135
http://www.mandriva.com/security/
_______________________________________________________________________

Package : webmin
Date : June 23, 2007
Affected: 2007.0, 2007.1, Corporate 4.0
_______________________________________________________________________

Problem Description:

Multiple cross-site scripting (XSS) vulnerabilities were discovered
in pam_login.cgi in webmin prior to version 1.350, which could allow
a remote attacker to inject arbitrary web script or HTML.

Updated packages have been patched to prevent this issue.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-3156
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2007.0:
b8981f770501be8eccacb49eef5ed40d 2007.0/i586/webmin-1.290-4.4mdv2007.0.noarch.rpm
0247107019e5b014d1931d1bc9efbc8a 2007.0/SRPMS/webmin-1.290-4.4mdv2007.0.src.rpm

Mandriva Linux 2007.0/X86_64:
b8981f770501be8eccacb49eef5ed40d 2007.0/x86_64/webmin-1.290-4.4mdv2007.0.noarch.rpm
0247107019e5b014d1931d1bc9efbc8a 2007.0/SRPMS/webmin-1.290-4.4mdv2007.0.src.rpm

Mandriva Linux 2007.1:
143e2320e03544c7a40d11c6e0aacaa6 2007.1/i586/webmin-1.320-1.1mdv2007.1.noarch.rpm
15e22c891aed715223d5d655c2076691 2007.1/SRPMS/webmin-1.320-1.1mdv2007.1.src.rpm

Mandriva Linux 2007.1/X86_64:
143e2320e03544c7a40d11c6e0aacaa6 2007.1/x86_64/webmin-1.320-1.1mdv2007.1.noarch.rpm
15e22c891aed715223d5d655c2076691 2007.1/SRPMS/webmin-1.320-1.1mdv2007.1.src.rpm

Corporate 4.0:
b84091c9b3a44dd5dcf7e1945661bfb4 corporate/4.0/i586/webmin-1.220-9.8.20060mlcs4.noarch.rpm
5715885df4fcddade5de4b0fdddcaa32 corporate/4.0/SRPMS/webmin-1.220-9.8.20060mlcs4.src.rpm

Corporate 4.0/X86_64:
b84091c9b3a44dd5dcf7e1945661bfb4 corporate/4.0/x86_64/webmin-1.220-9.8.20060mlcs4.noarch.rpm
5715885df4fcddade5de4b0fdddcaa32 corporate/4.0/SRPMS/webmin-1.220-9.8.20060mlcs4.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
lt;security*mandriva.comgt;
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)

iD8DBQFGfDJ8mqjQ0CJFipgRAt+IAKDcXdUoZh07acfRhsgJVUI6Jk7W8QCfe/gK
dul83B0vtcP65zOjWdchgM0=
=qMMp
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/security_announce_mdksa_2007135__updated_webmin_packages_fix_xss_vulnerability.html)